summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-21 18:56:28 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-21 18:56:28 +0100
commit80981bc4a9afe1fcbb0958d971905d3b446160dc (patch)
treed30abb341e5de1625429eb430a3e06923e7957f1 /dev-python/ujson/ujson-4.0.2.ebuild
parentdev-util/cppunit: Fixed build with sys-devel/slibtool (diff)
downloadgentoo-80981bc4a9afe1fcbb0958d971905d3b446160dc.tar.gz
gentoo-80981bc4a9afe1fcbb0958d971905d3b446160dc.tar.bz2
gentoo-80981bc4a9afe1fcbb0958d971905d3b446160dc.zip
dev-python/ujson: Bump to 4.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ujson/ujson-4.0.2.ebuild')
-rw-r--r--dev-python/ujson/ujson-4.0.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/ujson/ujson-4.0.2.ebuild b/dev-python/ujson/ujson-4.0.2.ebuild
new file mode 100644
index 000000000000..cf43a19546ea
--- /dev/null
+++ b/dev-python/ujson/ujson-4.0.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Ultra fast JSON encoder and decoder for Python"
+HOMEPAGE="https://pypi.org/project/ujson/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/pytz[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest