summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-12 08:26:06 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-12 11:11:34 +0200
commit581236b5f97942840d11e1640c9f321779e39aea (patch)
tree6eaaab62529d76b44b349faedf73a18714fefc7a /dev-python/uncertainties/uncertainties-3.1.6.ebuild
parentdev-python/hypothesis: Bump to 6.14.2 (diff)
downloadgentoo-581236b5f97942840d11e1640c9f321779e39aea.tar.gz
gentoo-581236b5f97942840d11e1640c9f321779e39aea.tar.bz2
gentoo-581236b5f97942840d11e1640c9f321779e39aea.zip
dev-python/uncertainties: Bump to 3.1.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/uncertainties/uncertainties-3.1.6.ebuild')
-rw-r--r--dev-python/uncertainties/uncertainties-3.1.6.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/uncertainties/uncertainties-3.1.6.ebuild b/dev-python/uncertainties/uncertainties-3.1.6.ebuild
new file mode 100644
index 000000000000..96b4e0d8f983
--- /dev/null
+++ b/dev-python/uncertainties/uncertainties-3.1.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python module for calculations with uncertainties"
+HOMEPAGE="https://pythonhosted.org/uncertainties/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests nose
+
+python_compile_all() {
+ use doc && "${PYTHON}" setup.py build_sphinx
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( build/sphinx/html/. )
+ distutils-r1_python_install_all
+}