summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Perlov <perlovka@gmail.com>2018-07-12 13:22:29 +0300
committerAmy Liffey <amynka@gentoo.org>2018-07-16 18:04:11 +0100
commit375ca82bf66396a8c9289abd2a4cccc375eb7c39 (patch)
tree7063d1f26b8595f806cdda9a8434f8ce93fe9fdc /dev-python/uranium/uranium-3.4.1.ebuild
parentdev-libs/libsavitar: version bump to 3.4.1 (diff)
downloadgentoo-375ca82bf66396a8c9289abd2a4cccc375eb7c39.tar.gz
gentoo-375ca82bf66396a8c9289abd2a4cccc375eb7c39.tar.bz2
gentoo-375ca82bf66396a8c9289abd2a4cccc375eb7c39.zip
dev-python/uranium: version bump to 3.4.1
Bug: https://bugs.gentoo.org/660884 Package-Manager: Portage-2.3.42, Repoman-2.3.9
Diffstat (limited to 'dev-python/uranium/uranium-3.4.1.ebuild')
-rw-r--r--dev-python/uranium/uranium-3.4.1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/uranium/uranium-3.4.1.ebuild b/dev-python/uranium/uranium-3.4.1.ebuild
new file mode 100644
index 000000000000..ea926475cda6
--- /dev/null
+++ b/dev-python/uranium/uranium-3.4.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit cmake-utils python-single-r1
+
+MY_PN="Uranium"
+
+DESCRIPTION="A Python framework for building 3D printing related applications"
+HOMEPAGE="https://github.com/Ultimaker/Uranium"
+SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ ~dev-libs/libarcus-${PV}:=[python,${PYTHON_USEDEP}]
+ <dev-python/PyQt5-5.10[${PYTHON_USEDEP},declarative,network,svg]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=sci-libs/scipy-1.1[${PYTHON_USEDEP}]
+ dev-qt/qtquickcontrols:5
+ dev-qt/qtquickcontrols2:5"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ doc? ( app-doc/doxygen )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+DOCS=( README.md )
+
+PATCHES=( "${FILESDIR}/${PN}-3.3.0-fix-install-paths.patch" )
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DPYTHON_SITE_PACKAGES_DIR="$(python_get_sitedir)" )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use doc; then
+ cmake-utils_src_compile doc
+ DOCS+=( html )
+ fi
+}
+
+src_test() {
+ emake -C "${BUILD_DIR}" tests
+}
+
+src_install() {
+ cmake-utils_src_install
+ python_optimize "${D}usr/$(get_libdir)"
+}