summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-08-21 16:02:49 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-08-21 16:03:09 +0300
commite969d93c4049a024bf9b874a917f902d2977e576 (patch)
treeaf73d2bad83159888516053b6bc182d5e03b91b8 /dev-python/urlgrabber
parentdev-python/zconfig: drop 3.5.0 (diff)
downloadgentoo-e969d93c4049a024bf9b874a917f902d2977e576.tar.gz
gentoo-e969d93c4049a024bf9b874a917f902d2977e576.tar.bz2
gentoo-e969d93c4049a024bf9b874a917f902d2977e576.zip
dev-python/urlgrabber: enable py3.10, use test_network
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/urlgrabber')
-rw-r--r--dev-python/urlgrabber/urlgrabber-4.1.0.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/urlgrabber/urlgrabber-4.1.0.ebuild b/dev-python/urlgrabber/urlgrabber-4.1.0.ebuild
index 5c5de9784b61..bf5bbc2a7c6a 100644
--- a/dev-python/urlgrabber/urlgrabber-4.1.0.ebuild
+++ b/dev-python/urlgrabber/urlgrabber-4.1.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -15,6 +15,9 @@ S="${WORKDIR}/${PN}-${PN}-${PV//./-}"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 ~arm ~ia64 ppc ppc64 x86"
+
+# Entire testsuite relies on connecting to the i'net
+PROPERTIES="test_network"
RESTRICT="test"
RDEPEND="
@@ -30,8 +33,7 @@ PATCHES=(
)
python_test() {
- # Entire testsuite relies on connecting to the i'net, added for reference
URLGRABBER_EXT_DOWN="${S}/scripts/urlgrabber-ext-down" \
PYTHON_PATH="${S}" \
- "${PYTHON}" test/runtests.py -v 2 || die "tests failed under ${EPYTHON}"
+ "${EPYTHON}" test/runtests.py -v 2 || die "Tests failed under ${EPYTHON}"
}