summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-05 20:09:48 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-05 20:09:48 +0100
commitf064d9c5e2876e5c7b9fbbc3f909584d1540c41d (patch)
tree3331d91335c022d316ec8b342717a62bc42909f8 /dev-python/utidylib
parentdev-python/jupyter-lsp: Bump to 2.2.4 (diff)
downloadgentoo-f064d9c5e2876e5c7b9fbbc3f909584d1540c41d.tar.gz
gentoo-f064d9c5e2876e5c7b9fbbc3f909584d1540c41d.tar.bz2
gentoo-f064d9c5e2876e5c7b9fbbc3f909584d1540c41d.zip
dev-python/utidylib: Bump to 0.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/utidylib')
-rw-r--r--dev-python/utidylib/Manifest1
-rw-r--r--dev-python/utidylib/utidylib-0.10.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/utidylib/Manifest b/dev-python/utidylib/Manifest
index 5af7559ce235..d5981c7e62f5 100644
--- a/dev-python/utidylib/Manifest
+++ b/dev-python/utidylib/Manifest
@@ -1 +1,2 @@
+DIST utidylib-0.10.gh.tar.gz 16810 BLAKE2B ae8dc947c9af0a900c1d371788078a921115d84f14a9b1d00f16d0cc4461584ee9307a6431021c0c4e9e91807964baed898faa1e1313f9c4122b0d70a85a3b17 SHA512 80e59cb909d1c2f3fd7a0df604cf75ebcb335df02d8f2e4df4f619abe7cd3bcba1ffd9432a98aa65f50976ed811fe24bba1306e0cbdc86327d56c17ea8bd083e
DIST utidylib-0.9.gh.tar.gz 15778 BLAKE2B 54c9b9b7c0615ac49a90567357f119643311dd6ee2848dcdfcbe00b93431672ee6954738627c0b3fa984a8f2c7b9e127cc1edac06f9760a252621317d2266476 SHA512 58ca8a43ba2e933f02111939ee8496bb63b17220ce5a6fa3cb731659e89000baa17409c10968308cd86bb2a9dc4819ef2029245eecdb3c7a3fa57404f37004fc
diff --git a/dev-python/utidylib/utidylib-0.10.ebuild b/dev-python/utidylib/utidylib-0.10.ebuild
new file mode 100644
index 000000000000..2db183b0adaa
--- /dev/null
+++ b/dev-python/utidylib/utidylib-0.10.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="TidyLib Python wrapper"
+HOMEPAGE="
+ https://cihar.com/software/utidylib/
+ https://github.com/nijel/utidylib/
+ https://pypi.org/project/uTidylib/
+"
+SRC_URI="
+ https://github.com/nijel/utidylib/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=app-text/htmltidy-5.0.0
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/furo