summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-05-30 15:37:46 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-05-30 15:37:46 +0200
commit356e7c69b66c9a0a6807d82f8b678fe7a424c110 (patch)
treea99d1ee3bdb2a462c7ed132e76f6a61ff6de024a /dev-python/vcrpy/vcrpy-1.11.1.ebuild
parentdev-libs/mongo-c-driver: fix building with libressl (bug #618988) (diff)
downloadgentoo-356e7c69b66c9a0a6807d82f8b678fe7a424c110.tar.gz
gentoo-356e7c69b66c9a0a6807d82f8b678fe7a424c110.tar.bz2
gentoo-356e7c69b66c9a0a6807d82f8b678fe7a424c110.zip
dev-python/vcrpy: Version bump to 1.11.1
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python/vcrpy/vcrpy-1.11.1.ebuild')
-rw-r--r--dev-python/vcrpy/vcrpy-1.11.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/vcrpy/vcrpy-1.11.1.ebuild b/dev-python/vcrpy/vcrpy-1.11.1.ebuild
new file mode 100644
index 000000000000..b50e9d02784c
--- /dev/null
+++ b/dev-python/vcrpy/vcrpy-1.11.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically mock your HTTP interactions to simplify and speed up testing"
+HOMEPAGE="https://github.com/kevin1024/vcrpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+#SRC_URI="https://github.com/kevin1024/vcrpy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/wrapt[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep 'dev-python/contextlib2[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep 'dev-python/yarl[${PYTHON_USEDEP}]' python3*)
+ "
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -vv -x tests/unit || die
+}