summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-06-12 16:27:47 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-06-12 19:17:27 +0200
commitc0c66fe0a83c37cc95f94b396b8911d6b4adf810 (patch)
tree69703f6ae8544744e8768b9b5b2e49281bf031ca /dev-python/versioneer/versioneer-0.16.ebuild
parentapp-dicts/hunspell-kk: Remove unused eutils & git-r3 inherits (diff)
downloadgentoo-c0c66fe0a83c37cc95f94b396b8911d6b4adf810.tar.gz
gentoo-c0c66fe0a83c37cc95f94b396b8911d6b4adf810.tar.bz2
gentoo-c0c66fe0a83c37cc95f94b396b8911d6b4adf810.zip
dev-python/versioneer: Bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-python/versioneer/versioneer-0.16.ebuild')
-rw-r--r--dev-python/versioneer/versioneer-0.16.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/versioneer/versioneer-0.16.ebuild b/dev-python/versioneer/versioneer-0.16.ebuild
new file mode 100644
index 000000000000..3cf25e52aed1
--- /dev/null
+++ b/dev-python/versioneer/versioneer-0.16.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Easy VCS-based management of project version strings"
+HOMEPAGE="https://pypi.python.org/pypi/versioneer https://github.com/warner/python-versioneer"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py make_versioneer
+ git config --global user.email "you@example.com"
+ git config --global user.name "Your Name"
+
+ ${PYTHON} test/git/test_git.py -v || die
+}