summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/virtualenv/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/virtualenv/files')
-rw-r--r--dev-python/virtualenv/files/virtualenv-1.8.2-no-versioned-script.patch10
-rw-r--r--dev-python/virtualenv/files/virtualenv-12.0-skip-broken-test.patch18
-rw-r--r--dev-python/virtualenv/files/virtualenv-12.1.1-skip-broken-test.patch19
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/virtualenv/files/virtualenv-1.8.2-no-versioned-script.patch b/dev-python/virtualenv/files/virtualenv-1.8.2-no-versioned-script.patch
new file mode 100644
index 000000000000..040e36794ba9
--- /dev/null
+++ b/dev-python/virtualenv/files/virtualenv-1.8.2-no-versioned-script.patch
@@ -0,0 +1,10 @@
+--- pypa-virtualenv-350c45d/setup.py
++++ pypa-virtualenv-350c45d/setup.py
+@@ -9,7 +9,6 @@
+ 'entry_points': {
+ 'console_scripts': [
+ 'virtualenv=virtualenv:main',
+- 'virtualenv-%s.%s=virtualenv:main' % sys.version_info[:2]
+ ],
+ },
+ 'zip_safe': False,
diff --git a/dev-python/virtualenv/files/virtualenv-12.0-skip-broken-test.patch b/dev-python/virtualenv/files/virtualenv-12.0-skip-broken-test.patch
new file mode 100644
index 000000000000..a7485e43d390
--- /dev/null
+++ b/dev-python/virtualenv/files/virtualenv-12.0-skip-broken-test.patch
@@ -0,0 +1,18 @@
+--- virtualenv-12.0/tests/test_virtualenv.py
++++ virtualenv-12.0/tests/test_virtualenv.py
+@@ -5,6 +5,7 @@
+ import sys
+ import tempfile
+ from mock import patch, Mock
++import unittest
+
+
+ def test_version():
+@@ -123,6 +124,7 @@
+ shutil.rmtree(tmp_virtualenv)
+
+
++@unittest.skip("Running create environment while testing is broken")
+ def test_always_copy_option():
+ """Should be no symlinks in directory tree"""
+ tmp_virtualenv = tempfile.mkdtemp()
diff --git a/dev-python/virtualenv/files/virtualenv-12.1.1-skip-broken-test.patch b/dev-python/virtualenv/files/virtualenv-12.1.1-skip-broken-test.patch
new file mode 100644
index 000000000000..5c14c3e22850
--- /dev/null
+++ b/dev-python/virtualenv/files/virtualenv-12.1.1-skip-broken-test.patch
@@ -0,0 +1,19 @@
+--- virtualenv-12.1.1/tests/test_virtualenv.py
++++ virtualenv-12.1.1/tests/test_virtualenv.py
+@@ -6,6 +6,7 @@
+ import tempfile
+ import pytest
+ import platform # noqa
++import unittest
+
+ from mock import patch, Mock
+
+@@ -126,7 +127,7 @@
+ shutil.rmtree(tmp_virtualenv)
+
+
+-@pytest.mark.skipif("platform.python_implementation() == 'PyPy'")
++@unittest.skip("Running create environment while testing is broken")
+ def test_always_copy_option():
+ """Should be no symlinks in directory tree"""
+ tmp_virtualenv = tempfile.mkdtemp()