summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-08 17:36:08 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-08 19:39:14 +0100
commitebc11b54bd4e0b5bbdb9609ba7eb799afc250404 (patch)
treec75138764c8824aa69b9dd70e9908ba420fd34d0 /dev-python/virtualenv/virtualenv-14.0.6.ebuild
parentdev-python/packaging: Version Bump (diff)
downloadgentoo-ebc11b54bd4e0b5bbdb9609ba7eb799afc250404.tar.gz
gentoo-ebc11b54bd4e0b5bbdb9609ba7eb799afc250404.tar.bz2
gentoo-ebc11b54bd4e0b5bbdb9609ba7eb799afc250404.zip
dev-python/virtualenv: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/virtualenv/virtualenv-14.0.6.ebuild')
-rw-r--r--dev-python/virtualenv/virtualenv-14.0.6.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/virtualenv/virtualenv-14.0.6.ebuild b/dev-python/virtualenv/virtualenv-14.0.6.ebuild
new file mode 100644
index 000000000000..8237a676fb3f
--- /dev/null
+++ b/dev-python/virtualenv/virtualenv-14.0.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Virtual Python Environment builder"
+HOMEPAGE="
+ http://www.virtualenv.org/
+ https://pypi.python.org/pypi/virtualenv
+ https://github.com/pypa/virtualenv/
+"
+SRC_URI="https://github.com/pypa/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( docs/index.rst docs/changes.rst )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.2-no-versioned-script.patch
+ "${FILESDIR}"/${PN}-12.1.1-skip-broken-test.patch
+)
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test -v -v || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${S}"/docs/_build/html/. )
+ distutils-r1_python_install_all
+}