summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-07-21 00:54:13 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-07-21 00:54:13 +0200
commit832d368428c88f570ed30370f90d02c4954aaa9c (patch)
tree583b81b75e539a4bbfdc3bca04f57b6168c939cf /dev-python/visitor
parentnet-p2p/torrentinfo: remove old (diff)
downloadgentoo-832d368428c88f570ed30370f90d02c4954aaa9c.tar.gz
gentoo-832d368428c88f570ed30370f90d02c4954aaa9c.tar.bz2
gentoo-832d368428c88f570ed30370f90d02c4954aaa9c.zip
dev-python/visitor: add Python 3.7 support
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'dev-python/visitor')
-rw-r--r--dev-python/visitor/visitor-0.1.3.ebuild7
1 files changed, 2 insertions, 5 deletions
diff --git a/dev-python/visitor/visitor-0.1.3.ebuild b/dev-python/visitor/visitor-0.1.3.ebuild
index b6ff311f6c16..56399f3c1fc5 100644
--- a/dev-python/visitor/visitor-0.1.3.ebuild
+++ b/dev-python/visitor/visitor-0.1.3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
inherit distutils-r1
@@ -19,11 +19,8 @@ IUSE="test"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
"
-RDEPEND=""
python_test() {
py.test || die "Tests failed with ${EPYTHON}"