summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2023-02-16 18:29:02 +0700
committerAndrey Grozin <grozin@gentoo.org>2023-02-16 18:29:02 +0700
commit203aa6a42d6217f45362b4035de72224a4b573da (patch)
tree211404c79c1a562f60c55aef8639821c82579f75 /dev-python/vpython
parentapp-text/foliate: remove old revision (diff)
downloadgentoo-203aa6a42d6217f45362b4035de72224a4b573da.tar.gz
gentoo-203aa6a42d6217f45362b4035de72224a4b573da.tar.bz2
gentoo-203aa6a42d6217f45362b4035de72224a4b573da.zip
dev-python/vpython: add python3_11
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'dev-python/vpython')
-rw-r--r--dev-python/vpython/vpython-7.6.4-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/vpython/vpython-7.6.4-r1.ebuild b/dev-python/vpython/vpython-7.6.4-r1.ebuild
new file mode 100644
index 000000000000..d7c13e25645c
--- /dev/null
+++ b/dev-python/vpython/vpython-7.6.4-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="VPython for Jupyter notebook"
+HOMEPAGE="https://www.vpython.org/ https://pypi.org/project/vpython/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/autobahn-18.8.2[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jupyter[${PYTHON_USEDEP}]
+ dev-python/jupyter-server-proxy[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+RESTRICT="test"
+
+distutils_enable_tests pytest