summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-28 15:09:31 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-28 15:29:59 +0200
commit6af6e8a8858411f8e2a51f3b9c0fd0223b467d92 (patch)
tree33f2ea739d709023ad3d0407eceb1c55b8d6885e /dev-python/watchgod
parentdev-python/wstools: Bump to 0.4.10 (diff)
downloadgentoo-6af6e8a8858411f8e2a51f3b9c0fd0223b467d92.tar.gz
gentoo-6af6e8a8858411f8e2a51f3b9c0fd0223b467d92.tar.bz2
gentoo-6af6e8a8858411f8e2a51f3b9c0fd0223b467d92.zip
dev-python/watchgod: Bump to 0.8.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/watchgod')
-rw-r--r--dev-python/watchgod/Manifest1
-rw-r--r--dev-python/watchgod/watchgod-0.8.2.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/watchgod/Manifest b/dev-python/watchgod/Manifest
index bc4b2f4231e7..ea262ed90e45 100644
--- a/dev-python/watchgod/Manifest
+++ b/dev-python/watchgod/Manifest
@@ -1 +1,2 @@
DIST watchfiles-0.8.1.gh.tar.gz 15405 BLAKE2B ea5d6d59b930f00d6b4b8d6236a38dbb2463866246f1ff4cda828a99a7383fac9c47b131417d8f375a105733c7567f32895759a8dc4503f5671b524977e282ed SHA512 2f611786d267ceae5d6e9094400f5dc6eb59a008f047a511b58b329762e63bbcd83a56cc95cca54c8480b1702c160548baa30549e907e6b85c8bf176ba339fb6
+DIST watchfiles-0.8.2.gh.tar.gz 15515 BLAKE2B 97c17737c6970c8b799707547cef760c307cd000d09cf3a338e47c0735d537e0321643066eab592f7f7e6ccc25272ea1e7e0bbc02f6274864f7cc39a177b83ba SHA512 a44b831352ace03c450781bc815b1813c44c386d666a9b724b562ff69228705651bfc23e81b7344d0f79c62577d4f910b323c734298e2a609f85bbc4a0f0498e
diff --git a/dev-python/watchgod/watchgod-0.8.2.ebuild b/dev-python/watchgod/watchgod-0.8.2.ebuild
new file mode 100644
index 000000000000..c40e10b7d38a
--- /dev/null
+++ b/dev-python/watchgod/watchgod-0.8.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=watchfiles-${PV}
+DESCRIPTION="Simple, modern file watching and code reload in Python"
+HOMEPAGE="
+ https://pypi.org/project/watchgod/
+ https://github.com/samuelcolvin/watchfiles/
+"
+SRC_URI="
+ https://github.com/samuelcolvin/watchfiles/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ =dev-python/anyio-3*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-toolbox[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # increase timeout
+ sed -e '/sleep/s/0.01/1.0/' -i tests/test_watch.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # flaky test on slow systems, https://github.com/samuelcolvin/watchgod/issues/84
+ tests/test_watch.py::test_awatch_log
+ )
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ tests/test_watch.py::test_does_not_exist
+ )
+ epytest
+}