summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-01 06:26:56 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-01 06:34:22 +0200
commit288c13254cfad38e032e4790fc19a8a77329eabb (patch)
tree6c09290cd74552695269c5ee001fa3ef0d4ebb63 /dev-python/weasyprint
parentdev-python/google-api-core: Bump to 2.19.0 (diff)
downloadgentoo-288c13254cfad38e032e4790fc19a8a77329eabb.tar.gz
gentoo-288c13254cfad38e032e4790fc19a8a77329eabb.tar.bz2
gentoo-288c13254cfad38e032e4790fc19a8a77329eabb.zip
dev-python/weasyprint: Bump to 62.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/weasyprint')
-rw-r--r--dev-python/weasyprint/Manifest1
-rw-r--r--dev-python/weasyprint/weasyprint-62.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/weasyprint/Manifest b/dev-python/weasyprint/Manifest
index 0f589282331a..c917bdb4ff36 100644
--- a/dev-python/weasyprint/Manifest
+++ b/dev-python/weasyprint/Manifest
@@ -1 +1,2 @@
DIST weasyprint-61.2.tar.gz 447333 BLAKE2B 753f80ee0756e75b46023d29b8409599de9ff9f7f338a7800cf917a012f61c6a50857af813e4cbfe1ddfa913f95befc43719688468449d6f1b8d8df3714a7895 SHA512 62c3afba18bcc141bc013b95848b0e2426160123533509b6e353caa6c33173266524be84b0a50443ac2549b1b8013e5eb915f54a68168d65e98c9251c4fdf339
+DIST weasyprint-62.0.tar.gz 475383 BLAKE2B 3c390c06366f280eb0f1a949cde2e073dbe5155db78b16d5c557c2c7a4a7ee22c5e22cc36ad000171471a7d027e2508df9363c99b6c9fb151eb3367e8c7b686f SHA512 83b5c9a20a9a8e8fdeb1f54182da2b821ad84510a71b1a66c33f31376c7b54e79c565d2de1b16051688fab505ce726430fc69b9358ea29b38d158f776744a738
diff --git a/dev-python/weasyprint/weasyprint-62.0.ebuild b/dev-python/weasyprint/weasyprint-62.0.ebuild
new file mode 100644
index 000000000000..ede5b4b196eb
--- /dev/null
+++ b/dev-python/weasyprint/weasyprint-62.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF"
+HOMEPAGE="
+ https://weasyprint.org/
+ https://github.com/Kozea/WeasyPrint/
+ https://pypi.org/project/weasyprint/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cffi-0.6:=[${PYTHON_USEDEP}]
+ >=dev-python/cssselect2-0.1[${PYTHON_USEDEP}]
+ >=dev-python/fonttools-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-1.1[${PYTHON_USEDEP}]
+ >=dev-python/pillow-4.0.0[jpeg,jpeg2k,${PYTHON_USEDEP}]
+ >=dev-python/pydyf-0.10.0[${PYTHON_USEDEP}]
+ >=dev-python/pyphen-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/tinycss2-1.3.0[${PYTHON_USEDEP}]
+ media-fonts/dejavu
+ x11-libs/pango
+"
+
+BDEPEND="
+ test? (
+ >=app-text/ghostscript-gpl-9.56.1-r3
+ media-fonts/ahem
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}