summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-10-31 16:47:51 -0500
committerAlex Brandt <alunduil@gentoo.org>2015-10-31 16:47:51 -0500
commitdb388ecb3b772d16c5d184882ba34137f284bbf8 (patch)
treed7486abfe410462bf47ac08df572370a447aed04 /dev-python/websocket-client/websocket-client-0.34.0.ebuild
parentdev-python/boto3: drop version 1.1.1 (diff)
downloadgentoo-db388ecb3b772d16c5d184882ba34137f284bbf8.tar.gz
gentoo-db388ecb3b772d16c5d184882ba34137f284bbf8.tar.bz2
gentoo-db388ecb3b772d16c5d184882ba34137f284bbf8.zip
dev-python/websocket-client: add version 0.34.0
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-python/websocket-client/websocket-client-0.34.0.ebuild')
-rw-r--r--dev-python/websocket-client/websocket-client-0.34.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/websocket-client/websocket-client-0.34.0.ebuild b/dev-python/websocket-client/websocket-client-0.34.0.ebuild
new file mode 100644
index 000000000000..de7e12040324
--- /dev/null
+++ b/dev-python/websocket-client/websocket-client-0.34.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PN=${PN//-/_}
+
+DESCRIPTION="WebSocket client for python. hybi13 is supported"
+HOMEPAGE="https://github.com/liris/websocket-client"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/backports-ssl-match-hostname[${PYTHON_USEDEP}]' 'python2*' )
+"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}