summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-15 15:12:31 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-15 15:14:33 +0200
commit5f5610f53991ddd2143c88bf2af8ea18bf1f8602 (patch)
treef591ac88ed9bf7a325e72f4a12934a582b7901fb /dev-python/webtest
parentdev-python/pyquery: Merge py3.13 revbump back (diff)
downloadgentoo-5f5610f53991ddd2143c88bf2af8ea18bf1f8602.tar.gz
gentoo-5f5610f53991ddd2143c88bf2af8ea18bf1f8602.tar.bz2
gentoo-5f5610f53991ddd2143c88bf2af8ea18bf1f8602.zip
dev-python/webtest: Merge py3.13 revbump back
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/webtest')
-rw-r--r--dev-python/webtest/webtest-3.0.0-r1.ebuild7
-rw-r--r--dev-python/webtest/webtest-3.0.0-r2.ebuild47
2 files changed, 5 insertions, 49 deletions
diff --git a/dev-python/webtest/webtest-3.0.0-r1.ebuild b/dev-python/webtest/webtest-3.0.0-r1.ebuild
index 0b2948bb5da8..1efd2b1c89d6 100644
--- a/dev-python/webtest/webtest-3.0.0-r1.ebuild
+++ b/dev-python/webtest/webtest-3.0.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -6,7 +6,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
PYPI_PN="WebTest"
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1 pypi
@@ -32,6 +32,9 @@ BDEPEND="
test? (
dev-python/pyquery[${PYTHON_USEDEP}]
dev-python/wsgiproxy2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/legacy-cgi[${PYTHON_USEDEP}]
+ ' 3.13)
)
"
diff --git a/dev-python/webtest/webtest-3.0.0-r2.ebuild b/dev-python/webtest/webtest-3.0.0-r2.ebuild
deleted file mode 100644
index 1ff513b356f8..000000000000
--- a/dev-python/webtest/webtest-3.0.0-r2.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYPI_PN="WebTest"
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Helper to test WSGI applications"
-HOMEPAGE="
- https://docs.pylonsproject.org/projects/webtest/en/latest/
- https://github.com/Pylons/webtest/
- https://pypi.org/project/WebTest/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/paste[${PYTHON_USEDEP}]
- dev-python/pastedeploy[${PYTHON_USEDEP}]
- >=dev-python/webob-1.2[${PYTHON_USEDEP}]
- >=dev-python/waitress-0.8.5[${PYTHON_USEDEP}]
- dev-python/beautifulsoup4[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pyquery[${PYTHON_USEDEP}]
- dev-python/wsgiproxy2[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/legacy-cgi[${PYTHON_USEDEP}]
- ' 3.13)
- )
-"
-
-PATCHES=(
- "${FILESDIR}/webtest-2.0.33-no-pylons-theme.patch"
- "${FILESDIR}/webtest-3.0.0-python3.12-unittest.patch"
-)
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest