summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-17 04:12:32 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-17 04:20:38 +0100
commitad8186599be0c8b5d813334352a6569140557a6a (patch)
tree41ca312b217b824365c77c5032bc72b4aa759143 /dev-python/whatthepatch
parentdev-python/sqlglot: Bump to 25.31.2 (diff)
downloadgentoo-ad8186599be0c8b5d813334352a6569140557a6a.tar.gz
gentoo-ad8186599be0c8b5d813334352a6569140557a6a.tar.bz2
gentoo-ad8186599be0c8b5d813334352a6569140557a6a.zip
dev-python/whatthepatch: Bump to 1.0.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/whatthepatch')
-rw-r--r--dev-python/whatthepatch/Manifest1
-rw-r--r--dev-python/whatthepatch/whatthepatch-1.0.7.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/whatthepatch/Manifest b/dev-python/whatthepatch/Manifest
index 42242fddf684..d3c30bbdf5b1 100644
--- a/dev-python/whatthepatch/Manifest
+++ b/dev-python/whatthepatch/Manifest
@@ -1 +1,2 @@
DIST whatthepatch-1.0.6.tar.gz 31849 BLAKE2B cc540aa7455098a6f48e180defb173d25cc499d2c7415c639aef125cf0137e67c06ecdf18fb3337ef13e76e505ff598caa1b6a3d603c66dd38cb65f3f0a964ed SHA512 353866973b6a9b1d0bdb566d4c2eaf655a9a148d1acd73138cbbb5fbf5ec1d159391390857a34dfd75dca0c760168be720961e9d0d74dd8425849d641b2f5105
+DIST whatthepatch-1.0.7.tar.gz 34612 BLAKE2B a7a442ad4d00276c5fa3cdffd731f586faec512e93bb378e1e487cc87e54c4904a440573b230adab0da904bfa7134b9668a026fcb6538584abb20d2586386a57 SHA512 13df7e993babfc057d1e6bc1636d3153d68d860614b744da035d47d2acaeb5317067558a8f48d9b4014fdd8ff0caeb2fbe439d1004886667606bec3000f33987
diff --git a/dev-python/whatthepatch/whatthepatch-1.0.7.ebuild b/dev-python/whatthepatch/whatthepatch-1.0.7.ebuild
new file mode 100644
index 000000000000..8480a90dc46d
--- /dev/null
+++ b/dev-python/whatthepatch/whatthepatch-1.0.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A patch parsing and application library."
+HOMEPAGE="
+ https://github.com/cscorley/whatthepatch/
+ https://pypi.org/project/whatthepatch/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+EPYTEST_DESELECT=(
+ # the test measures performance of the patch parser together with test data
+ # preparation, which can take long time in some interpreters, bug #907243
+ tests/test_patch.py::PatchTestSuite::test_huge_patch
+)
+
+distutils_enable_tests pytest