summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-17 14:01:04 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-17 14:21:09 +0300
commitd733cf8b9e95fc5954051cab5045fcd260e11b86 (patch)
treefab6e52fab4681f3c81929bc8be677c712949e19 /dev-python/whichcraft
parentpackage.deprecated: Add dev-python/versioneer (diff)
downloadgentoo-d733cf8b9e95fc5954051cab5045fcd260e11b86.tar.gz
gentoo-d733cf8b9e95fc5954051cab5045fcd260e11b86.tar.bz2
gentoo-d733cf8b9e95fc5954051cab5045fcd260e11b86.zip
dev-python/whichcraft: EAPI=8, Use PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/whichcraft')
-rw-r--r--dev-python/whichcraft/whichcraft-0.6.1-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/whichcraft/whichcraft-0.6.1-r1.ebuild b/dev-python/whichcraft/whichcraft-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..fad9f2026fdb
--- /dev/null
+++ b/dev-python/whichcraft/whichcraft-0.6.1-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Cross-platform cross-python shutil.which functionality"
+HOMEPAGE="https://github.com/cookiecutter/whichcraft"
+SRC_URI="https://github.com/cookiecutter/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOCS=( README.rst HISTORY.rst CONTRIBUTING.rst )
+
+distutils_enable_tests pytest