summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2019-06-17 17:00:43 +0800
committerJason Zaman <perfinion@gentoo.org>2019-06-19 12:03:25 +0800
commit0da9fc040ec3b0f574af036ba821c16a5e936123 (patch)
tree1ca9f65269bfc0432a1080ba0ebf9845276b5021 /dev-python/wrapt/wrapt-1.11.2.ebuild
parentdev-python/google-pasta: bump 0.1.7 (diff)
downloadgentoo-0da9fc040ec3b0f574af036ba821c16a5e936123.tar.gz
gentoo-0da9fc040ec3b0f574af036ba821c16a5e936123.tar.bz2
gentoo-0da9fc040ec3b0f574af036ba821c16a5e936123.zip
dev-python/wrapt: bump 1.11.2
Signed-off-by: Jason Zaman <perfinion@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'dev-python/wrapt/wrapt-1.11.2.ebuild')
-rw-r--r--dev-python/wrapt/wrapt-1.11.2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/wrapt/wrapt-1.11.2.ebuild b/dev-python/wrapt/wrapt-1.11.2.ebuild
new file mode 100644
index 000000000000..fb3261b28fc7
--- /dev/null
+++ b/dev-python/wrapt/wrapt-1.11.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for decorators, wrappers and monkey patching"
+HOMEPAGE="https://github.com/GrahamDumpleton/wrapt"
+SRC_URI="https://github.com/GrahamDumpleton/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc test"
+
+DEPEND="
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND=""
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_compile() {
+ local WRAPT_EXTENSIONS=true
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ py.test -vv || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}