summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-14 02:49:02 +0000
committerSam James <sam@gentoo.org>2020-12-14 02:49:02 +0000
commitdd414b9559e82edecd653261697639fc40bb1b74 (patch)
tree4d89fe516fe3566e14cab16c0894d69b2fe21c52 /dev-python/wsaccel/wsaccel-0.6.3.ebuild
parentdev-python/cx_Freeze: bump to 6.4.2 (diff)
downloadgentoo-dd414b9559e82edecd653261697639fc40bb1b74.tar.gz
gentoo-dd414b9559e82edecd653261697639fc40bb1b74.tar.bz2
gentoo-dd414b9559e82edecd653261697639fc40bb1b74.zip
dev-python/wsaccel: bump to 0.6.3
Package-Manager: Portage-3.0.12-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/wsaccel/wsaccel-0.6.3.ebuild')
-rw-r--r--dev-python/wsaccel/wsaccel-0.6.3.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/wsaccel/wsaccel-0.6.3.ebuild b/dev-python/wsaccel/wsaccel-0.6.3.ebuild
new file mode 100644
index 000000000000..c71afde7b931
--- /dev/null
+++ b/dev-python/wsaccel/wsaccel-0.6.3.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Accelerator for ws4py, autobahn and tornado"
+HOMEPAGE="https://pypi.org/project/wsaccel/ https://github.com/methane/wsaccel"
+SRC_URI="https://github.com/methane/wsaccel/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest