summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-07-07 19:46:53 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-07-07 20:14:45 +0300
commita1c75a9c0089c1474a32dc271e9266bba6d5af11 (patch)
treef8bd6d4c1a66450d6460f182b5fde9bdc1e9fd5a /dev-python/xkbcommon
parentdev-python/pytest-subtests: add 0.13.0 (diff)
downloadgentoo-a1c75a9c0089c1474a32dc271e9266bba6d5af11.tar.gz
gentoo-a1c75a9c0089c1474a32dc271e9266bba6d5af11.tar.bz2
gentoo-a1c75a9c0089c1474a32dc271e9266bba6d5af11.zip
dev-python/xkbcommon: add 1.5.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/xkbcommon')
-rw-r--r--dev-python/xkbcommon/Manifest1
-rw-r--r--dev-python/xkbcommon/xkbcommon-1.5.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/xkbcommon/Manifest b/dev-python/xkbcommon/Manifest
index db7797541650..ee7bc794e800 100644
--- a/dev-python/xkbcommon/Manifest
+++ b/dev-python/xkbcommon/Manifest
@@ -1,3 +1,4 @@
DIST python-xkbcommon-1.0.1.gh.tar.gz 79263 BLAKE2B 8bc128e592a02b14321fe087f7c0ae87a699e0284c3230fa2a0b1cf2e8105037fa0ace876216ec8a72cc49eb76fab0af83b7a5d83a3943f609954205d949def0 SHA512 1e0393c5d7e99d9a68168a5486a15b3598d8539b7a7b0a7c41a9c1a329cfe79d3f19556b481f5625e1bea1cc41f3394dcc1fc1bf1dbd98cd58db54f471ece5d5
DIST python-xkbcommon-1.0.gh.tar.gz 27258 BLAKE2B 3106877f8e87f50453a358eec4e6431642b00a6a2bc23d3088ef22379984869ec84cd042a1ac53dd72783f3005dad1efddf3f87410204b88bfde4f9da0044c97 SHA512 c7793d6f5517771006ff5a9c01deb9a37717157d7171af49ff459dc96b3b16a1d2d4c0f1272b5a8f683390de1e8e6a6ff92472f18828c7e38e0f2a1ee6f34f07
+DIST xkbcommon-1.5.1.tar.gz 80170 BLAKE2B 8dec8c632d1d3c5d4f47992feea7431e21a9bb6477cbb35039003606ad6c52136255e89373bfe663cfaeb5d7b575ca0504af05568d56dcf99c53f509cf636408 SHA512 0fe7fa5760a77f9652e1985d16bf9ef0f6a95f96a196a032f4d7639bca5da644e0439f81ff76b02a06a2e2448277d86ed798de72cbfadeb2369ffaf2d322cb65
DIST xkbcommon-1.5.tar.gz 79887 BLAKE2B f6a39b98fc97f12a2badfa53cf5445fad0018aaf03542d1945d36155e3c0abe92b4080f149d8c2bcc85ac72cef6a6099ca45afb043754b31a543f02820a33ebd SHA512 ab0d3f83d11038dd4ae98f9954f6082f214727720d0eced4c298943f4f26b19d9be42bc4215c4e6a5fa68214c4a0a5e88b30657a52e982a8b4c7e7b84c1c174b
diff --git a/dev-python/xkbcommon/xkbcommon-1.5.1.ebuild b/dev-python/xkbcommon/xkbcommon-1.5.1.ebuild
new file mode 100644
index 000000000000..ff9443b3c9b7
--- /dev/null
+++ b/dev-python/xkbcommon/xkbcommon-1.5.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings for libxkbcommon using cffi"
+HOMEPAGE="
+ https://github.com/sde1000/python-xkbcommon/
+ https://pypi.org/project/xkbcommon/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+# x11-libs/libxkbcommon dep per README
+RDEPEND="
+ >=x11-libs/libxkbcommon-${PV}
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+python_test() {
+ rm -rf xkbcommon || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}