summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-08 04:51:27 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-08 04:51:27 +0200
commit4ba712a5d00bde54610eb5aac2eb0c3eda8bc97c (patch)
tree489de2066bb1f7af3c0f25cbc229f4b11ae91959 /dev-python/xmlschema
parentdev-python/flask: Bump to 3.0.3 (diff)
downloadgentoo-4ba712a5d00bde54610eb5aac2eb0c3eda8bc97c.tar.gz
gentoo-4ba712a5d00bde54610eb5aac2eb0c3eda8bc97c.tar.bz2
gentoo-4ba712a5d00bde54610eb5aac2eb0c3eda8bc97c.zip
dev-python/xmlschema: Bump to 3.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xmlschema')
-rw-r--r--dev-python/xmlschema/Manifest1
-rw-r--r--dev-python/xmlschema/xmlschema-3.2.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/xmlschema/Manifest b/dev-python/xmlschema/Manifest
index 16d33aeb22eb..34f62a4b1e39 100644
--- a/dev-python/xmlschema/Manifest
+++ b/dev-python/xmlschema/Manifest
@@ -1,2 +1,3 @@
DIST xmlschema-3.1.0.tar.gz 566760 BLAKE2B d8d1dc61e5eb6897d128ba9ed5257b65190af948946b7ac5d5b9b5fdeb14df42e8a298bc0ed7cdec58cabd237e0c950465bf58be702610496a16000a2f23f354 SHA512 26d6586ede499907bc2b7f0b58c75460d4bfa3761bc029a042e32ede2237234daa8be7b4602da7dec2e28aa945f24e1726fd445189ec31ce4af89c9c5762e1ef
DIST xmlschema-3.2.0.tar.gz 570442 BLAKE2B 0910a417a608e99850874a15ed608b0e33abb4a3a76c0bd0101eb3fdef89087f1f1c44ca59bc08ee6992eee24ed433bb602626fef0ffe76b671f8a5b33d662a7 SHA512 90d3e6b92054ec9eaead6c79543dceb819b75e94c19e2991671708443cb713fc9b7925d1ae09fe40d1522a27369b729528ab758087b9de0cc0157227abb95f3a
+DIST xmlschema-3.2.1.tar.gz 571883 BLAKE2B 1c5202af6f3e1aca99898442f0efb47fd72c0f32e42d0ad4d527e5f4849195b8298656ba214c8578ed5a3cabca3232102e778667062139955fbae39610d90559 SHA512 ea65d79c628eca1b4becefee0f8a79e5a5c9a43072747d7b5b312e152c953a45727e3945bd2755a37ef28e2f010148879ca32a42516254eccba0bc3bb371c2ff
diff --git a/dev-python/xmlschema/xmlschema-3.2.1.ebuild b/dev-python/xmlschema/xmlschema-3.2.1.ebuild
new file mode 100644
index 000000000000..d38ccad42ce5
--- /dev/null
+++ b/dev-python/xmlschema/xmlschema-3.2.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="An XML Schema validator and decoder"
+HOMEPAGE="
+ https://github.com/sissaschool/xmlschema/
+ https://pypi.org/project/xmlschema/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ <dev-python/elementpath-5[${PYTHON_USEDEP}]
+ >=dev-python/elementpath-4.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ "${EPYTHON}" tests/test_all.py -v || die "Tests fail with ${EPYTHON}"
+}