summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-19 05:03:10 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-19 05:10:38 +0100
commit828c8b3ff1aa7bdb60a96e6884df5cb021792d5a (patch)
treecac2bc77f1fc2c55c0fa227f83891d9125b293b6 /dev-python/xmlschema
parentdev-python/pykka: Bump to 4.0.2 (diff)
downloadgentoo-828c8b3ff1aa7bdb60a96e6884df5cb021792d5a.tar.gz
gentoo-828c8b3ff1aa7bdb60a96e6884df5cb021792d5a.tar.bz2
gentoo-828c8b3ff1aa7bdb60a96e6884df5cb021792d5a.zip
dev-python/xmlschema: Bump to 3.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xmlschema')
-rw-r--r--dev-python/xmlschema/Manifest1
-rw-r--r--dev-python/xmlschema/xmlschema-3.0.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/xmlschema/Manifest b/dev-python/xmlschema/Manifest
index b5855261fb85..b492e799b808 100644
--- a/dev-python/xmlschema/Manifest
+++ b/dev-python/xmlschema/Manifest
@@ -1 +1,2 @@
DIST xmlschema-3.0.1.tar.gz 560537 BLAKE2B 236794db504d3ff6e9e98a03d6e0b25211c76779eac665b69ddd58e98bbbd02dcf1ab6b8aa0430989fedf2c67efcb6999e29fdb9fce09241a0955e32ae76890c SHA512 0266b75c371a3b77a86a7a5380d6bafb14bd8a8b5c58d891825cf708891293f9bf10b4bf1d1a9b71efc43a40115baa51d02e3adb8dbddfe79e4dd56ed07951b9
+DIST xmlschema-3.0.2.tar.gz 563203 BLAKE2B a8b31b435d159df65a620d26a7e964745b9a7e6050a32c52bfa039a013e9108b601cdd2a1188503f327900712b2b445dc4279cc50ee3c62022517afc5dfe6425 SHA512 93062230b13bdcc30eed0291c295bdd8eccb50d5d07c8747336c2917e5d949b30f46d1b90f501fb6da06ceda99d162da92b8db9e206fff09fc3c362b05499903
diff --git a/dev-python/xmlschema/xmlschema-3.0.2.ebuild b/dev-python/xmlschema/xmlschema-3.0.2.ebuild
new file mode 100644
index 000000000000..f8430a380efa
--- /dev/null
+++ b/dev-python/xmlschema/xmlschema-3.0.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="An XML Schema validator and decoder"
+HOMEPAGE="
+ https://github.com/sissaschool/xmlschema/
+ https://pypi.org/project/xmlschema/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ <dev-python/elementpath-5[${PYTHON_USEDEP}]
+ >=dev-python/elementpath-4.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ "${EPYTHON}" tests/test_all.py -v || die "Tests fail with ${EPYTHON}"
+}