summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2021-01-04 14:14:02 -0800
committerPatrick McLean <chutzpah@gentoo.org>2021-01-04 14:15:53 -0800
commit41aea449f656ec991454acb06d4ab81e6733cb0f (patch)
tree2ea2d1e660e705502300245cde0ed3433a7986ab /dev-python/yappi
parentsci-electronics/iverilog: Fixed build with ~sys-devel/autoconf-2.70 (diff)
downloadgentoo-41aea449f656ec991454acb06d4ab81e6733cb0f.tar.gz
gentoo-41aea449f656ec991454acb06d4ab81e6733cb0f.tar.bz2
gentoo-41aea449f656ec991454acb06d4ab81e6733cb0f.zip
dev-python/yappi-1.3.2: Version bump
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/yappi')
-rw-r--r--dev-python/yappi/Manifest1
-rw-r--r--dev-python/yappi/yappi-1.3.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/yappi/Manifest b/dev-python/yappi/Manifest
index bd655310b9cc..15620f122210 100644
--- a/dev-python/yappi/Manifest
+++ b/dev-python/yappi/Manifest
@@ -1,2 +1,3 @@
DIST yappi-1.2.5.tar.gz 928100 BLAKE2B 1d303226821d53fb215ac29f8363d9f564f9f40096b5ba8f67475c4074012316f523afb6d770cff879038cd333ef7f050b29c015e2dd2e517859f66a0e1f36f3 SHA512 ec784e76b56e8bc0c3cfe07c90d0810fa90d5a7da62f36187e8a09a9d6e01f3c2d74320de3dd3f4bf1d4a9425fee319c7a575a9d35ad5412c1501c934f1ba353
DIST yappi-1.3.0.tar.gz 928100 BLAKE2B 1d303226821d53fb215ac29f8363d9f564f9f40096b5ba8f67475c4074012316f523afb6d770cff879038cd333ef7f050b29c015e2dd2e517859f66a0e1f36f3 SHA512 ec784e76b56e8bc0c3cfe07c90d0810fa90d5a7da62f36187e8a09a9d6e01f3c2d74320de3dd3f4bf1d4a9425fee319c7a575a9d35ad5412c1501c934f1ba353
+DIST yappi-1.3.2.tar.gz 936566 BLAKE2B 55f114b8ed8689944f8146cb283701b41f34e87f3e5104d7d8df239cd2afc24f1ca1bf86f99bf672735677005df6527c83c5306a7902ea45e335134a925d6e18 SHA512 7a555bf6db8d7b9d8b4e36ceda1a40319a3d0aa478c512fb0fbca678dd3966b1facffa7555dca1ffaf07461ed3ab81284bd643e331eb2e6d1ee9c99eab1acb55
diff --git a/dev-python/yappi/yappi-1.3.2.ebuild b/dev-python/yappi/yappi-1.3.2.ebuild
new file mode 100644
index 000000000000..ae71996be05c
--- /dev/null
+++ b/dev-python/yappi/yappi-1.3.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python3_{7..9})
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+# no tags on github, no tests on pypi
+COMMIT_HASH="c256f28d3ccc2bc1692a5a090dc8f774c4933c16"
+
+DESCRIPTION="Yet Another Python Profiler"
+HOMEPAGE="https://pypi.org/project/yappi/ https://github.com/sumerc/yappi"
+SRC_URI="https://github.com/sumerc/yappi/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT_HASH}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+#RDEPEND="
+# $(python_gen_cond_dep 'dev-python/contextvars[${PYTHON_USEDEP}]' 'python3_6')
+#"
+
+distutils_enable_tests unittest
+
+PATCHES=(
+ "${FILESDIR}/yappi-1.2.5-warnings.patch"
+ "${FILESDIR}/yappi-1.3.0-tests.patch"
+)
+
+python_prepare_all() {
+ cp tests/utils.py "${S}" || die
+ distutils-r1_python_prepare_all
+}