summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-26 06:39:24 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-26 07:36:32 +0200
commitf935b6651fc549699778aaa401404c9dac268552 (patch)
tree941a66481933924a1c83494d4f93f86486b5bd65 /dev-python/yarl
parentdev-python/flask: Bump to 2.3.1 (diff)
downloadgentoo-f935b6651fc549699778aaa401404c9dac268552.tar.gz
gentoo-f935b6651fc549699778aaa401404c9dac268552.tar.bz2
gentoo-f935b6651fc549699778aaa401404c9dac268552.zip
dev-python/yarl: Bump to 1.9.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/yarl')
-rw-r--r--dev-python/yarl/Manifest1
-rw-r--r--dev-python/yarl/yarl-1.9.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/yarl/Manifest b/dev-python/yarl/Manifest
index 35a42dcf86fb..1b976b3997c2 100644
--- a/dev-python/yarl/Manifest
+++ b/dev-python/yarl/Manifest
@@ -1,2 +1,3 @@
DIST yarl-1.8.2.gh.tar.gz 109938 BLAKE2B 1f2cec38bb681f6a59f10253c75e74912d482cdbe0e639e3ba0a43b9d6ab7b7edc1558c9fffaffd7aad9fa905d884e856ff7f7b69dd103800ef62f7f05de90b5 SHA512 d5dcebcec06d520b48a1d879671a92371bd89eabb7be700c129fcc45e763ecc0370cbb5e88c7b9be05ecb3317370231293a8c076ed68d71a36fe953219dd27ea
DIST yarl-1.9.1.tar.gz 184455 BLAKE2B 0d4127129832493e4ffa8e2389048d77c7df222809a551bb4ab8583e26b2a4db8876bf62bee7079bd4d1f1b9b55b4875678db84fca38c30b3453bd4117bd461c SHA512 a583bea632b96ef1448a5f28a03c139e822ddc7f5ee8c545994c2746b92022b9ea4d3d8c7ded374a9f3aca1ee22eacd1a31bf96d690eae1775954175393679d0
+DIST yarl-1.9.2.tar.gz 184673 BLAKE2B bb94131059d0cfaf88f04d62a44181245ebcb660cb44904f0b7e8d497905a16d0026aeff454b8179fab5342c6bf9c8d6aadade0d9f7c70321c71bbcc3998e9a3 SHA512 ffbb6df94220bb1561333f1ad69a70334328e2273ec5e91c2741f6fd5ca2f6dd38d5b5f617728797fce490accc2394a406a5f9b5b665af4746746229af0d7c5f
diff --git a/dev-python/yarl/yarl-1.9.2.ebuild b/dev-python/yarl/yarl-1.9.2.ebuild
new file mode 100644
index 000000000000..8cc9f27c1914
--- /dev/null
+++ b/dev-python/yarl/yarl-1.9.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Yet another URL library"
+HOMEPAGE="
+ https://github.com/aio-libs/yarl/
+ https://pypi.org/project/yarl/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/multidict-4.0[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/alabaster
+
+src_configure() {
+ set -- cython -3 yarl/_quoting_c.pyx
+ echo "${*}" >&2
+ "${@}" || die
+}
+
+python_test() {
+ cd tests || die
+ epytest --override-ini=addopts=
+}