summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-04 20:50:16 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-07 20:43:24 +0200
commit743b5c504e058d36b47e1574b5fe6f82dcf4118c (patch)
treeea7b914cdf90ff4a0bbf87eebc05baba20d2562c /dev-python/zc-buildout
parentdev-python/zope-testrunner: New package, test dep of zope.exceptions (diff)
downloadgentoo-743b5c504e058d36b47e1574b5fe6f82dcf4118c.tar.gz
gentoo-743b5c504e058d36b47e1574b5fe6f82dcf4118c.tar.bz2
gentoo-743b5c504e058d36b47e1574b5fe6f82dcf4118c.zip
dev-python/zc-buildout: Partially enable tests
Add missing test dependencies and python_test() implementation. Sadly, the tests fail hard with Python 3.
Diffstat (limited to 'dev-python/zc-buildout')
-rw-r--r--dev-python/zc-buildout/zc-buildout-2.5.3.ebuild18
1 files changed, 14 insertions, 4 deletions
diff --git a/dev-python/zc-buildout/zc-buildout-2.5.3.ebuild b/dev-python/zc-buildout/zc-buildout-2.5.3.ebuild
index a49133684c61..a5324fbf46e1 100644
--- a/dev-python/zc-buildout/zc-buildout-2.5.3.ebuild
+++ b/dev-python/zc-buildout/zc-buildout-2.5.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -16,18 +16,28 @@ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="ZPL"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="test"
RDEPEND=">=dev-python/setuptools-3.3[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ test? ( dev-python/zope-testing[${PYTHON_USEDEP}] )"
S="${WORKDIR}"/${MY_P}
DOCS=( README.rst doc/tutorial.txt )
-# Tests require zope packages absent from portage
# Prevent incorrect installation of data file
python_prepare_all() {
sed -e '/^ include_package_data/d' -i setup.py || die
distutils-r1_python_prepare_all
}
+
+python_test() {
+ if python_is_python3; then
+ ewarn "Tests are broken for ${EPYTHON}, skipping"
+ continue
+ fi
+
+ distutils_install_for_testing
+ "${PYTHON}" src/zc/buildout/tests.py || die "Tests fail with ${EPYTHON}"
+}