summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-25 08:46:24 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-25 09:02:00 +0100
commit0f1c352cfa57bc0ab028e78c862e0377c1135c8d (patch)
tree4be95d0df6a2f9f89474dff4bcba9258ef8f7cb1 /dev-python/zeroconf
parentapp-emulation/docker: Remove CONFIG_RT_GROUP_SCHED (diff)
downloadgentoo-0f1c352cfa57bc0ab028e78c862e0377c1135c8d.tar.gz
gentoo-0f1c352cfa57bc0ab028e78c862e0377c1135c8d.tar.bz2
gentoo-0f1c352cfa57bc0ab028e78c862e0377c1135c8d.zip
dev-python/zeroconf: Bump to 0.29.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zeroconf')
-rw-r--r--dev-python/zeroconf/Manifest1
-rw-r--r--dev-python/zeroconf/zeroconf-0.29.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index 26241cf27ca3..4c819336280e 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -1 +1,2 @@
DIST python-zeroconf-0.28.8.gh.tar.gz 62107 BLAKE2B 94b910be9f95f8b50bfcd5fca102663713234d40a0cf90c5b94b2ab4e85ffd7363747a0fee2f7a72a3bfb74faa1cab703dfb8bfe3cef80a0495efe2c81d0c2af SHA512 ba599fdd44ecdf3da71ee2a155a47e6cf91c8f4fe3efac428f6e99feda052019423a8a3e775d6cc4624697fbfcbe207829a41ad76105082fe62e81eead2f7a34
+DIST python-zeroconf-0.29.0.gh.tar.gz 62466 BLAKE2B 430a9f4d4460d66166a2484862a8dd3af65f3cfad0e25557648abf26ebe88a7ae581934273db270ff30fa4d714b32a822448b22fd7a95e9e382b68ffae9b66b4 SHA512 a084da17cda264b531e7f58975d30ae0b5adb98f33ca78d1e865e1450dc42ad2bca69bc319c268f7977e70e082ae713142a57f97a9f050486c47b50698002590
diff --git a/dev-python/zeroconf/zeroconf-0.29.0.ebuild b/dev-python/zeroconf/zeroconf-0.29.0.ebuild
new file mode 100644
index 000000000000..fc762bc9256f
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.29.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+MY_P=python-zeroconf-${PV}
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/jstasiak/python-zeroconf/
+ https://pypi.org/project/zeroconf/"
+SRC_URI="
+ https://github.com/jstasiak/python-zeroconf/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local excludes=(
+ zeroconf/test.py::Framework::test_launch_and_close
+ zeroconf/test.py::Framework::test_launch_and_close_v4_v6
+ zeroconf/test.py::Framework::test_launch_and_close_v6_only
+ zeroconf/test.py::ServiceTypesQuery::test_integration_with_listener_ipv6
+ )
+
+ epytest ${excludes[@]/#/--deselect } zeroconf/test.py
+}