summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-15 09:04:49 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-15 13:32:38 +0200
commit440b1e54818f1befd2c6a86a918228bbe2f45dc0 (patch)
treeb271413c154ad3bb916f3edf28cde7865b27d50c /dev-python/zeroconf
parentdev-python/pyghmi: Remove old (diff)
downloadgentoo-440b1e54818f1befd2c6a86a918228bbe2f45dc0.tar.gz
gentoo-440b1e54818f1befd2c6a86a918228bbe2f45dc0.tar.bz2
gentoo-440b1e54818f1befd2c6a86a918228bbe2f45dc0.zip
dev-python/zeroconf: Bump to 0.38.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zeroconf')
-rw-r--r--dev-python/zeroconf/Manifest1
-rw-r--r--dev-python/zeroconf/zeroconf-0.38.7.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index c3540d88e680..003ea3cb6cd2 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -1 +1,2 @@
DIST python-zeroconf-0.38.6.gh.tar.gz 134795 BLAKE2B 839d59d7c46d9ab16145e37bb58acc7a71072b00507ee0ae8325fea9a3ebc0e567f9e257937675f8eaf44095c7449f96e6bc42b82d34f75a39cc87fd29be2766 SHA512 274db525751191b0188a4f00505c795420f975de3f714f84f2207271ff484bb5de1c881c0ed00b1ad3a6265d5d461519cf46041ab907026d9e6937844bbab6af
+DIST python-zeroconf-0.38.7.gh.tar.gz 134866 BLAKE2B 060ffdc45d4ec8092cd278b99a74561fd1ea06aba3cdecadbd35c1c5e3f608befe3ced18009d8d64c5b37388ee57900b4b00a44c90d87923f259e798da5bb962 SHA512 a0ab90f30b843bc889daf95eab6d806a5e3fb4ffe5e3857c435f14a85de7b659b8386159f6428f05a34f2e3010f4582f7d3a55bbd6e6ede0008247821f666707
diff --git a/dev-python/zeroconf/zeroconf-0.38.7.ebuild b/dev-python/zeroconf/zeroconf-0.38.7.ebuild
new file mode 100644
index 000000000000..5fbfc422a51f
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.38.7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=python-zeroconf-${PV}
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/jstasiak/python-zeroconf/
+ https://pypi.org/project/zeroconf/
+"
+SRC_URI="
+ https://github.com/jstasiak/python-zeroconf/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+ tests/test_core.py::Framework::test_launch_and_close_v4_v6
+ tests/test_core.py::Framework::test_launch_and_close_v6_only
+ tests/services/test_types.py::ServiceTypesQuery::test_integration_with_listener_ipv6
+
+ # fragile to timeouts (?)
+ tests/services/test_browser.py::test_service_browser_expire_callbacks
+ tests/utils/test_asyncio.py::test_run_coro_with_timeout
+)