summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-02-15 23:24:52 +0100
committerLouis Sautier <sbraz@gentoo.org>2020-02-16 10:25:51 +0100
commit95823c7f7b3f0203a43f7ce7d246a6764685b700 (patch)
treed1120d83dda3f8fcf66c34964b7d5b58dae44020 /dev-python/zipp
parentdev-libs/xmlrpc-c: drop old (diff)
downloadgentoo-95823c7f7b3f0203a43f7ce7d246a6764685b700.tar.gz
gentoo-95823c7f7b3f0203a43f7ce7d246a6764685b700.tar.bz2
gentoo-95823c7f7b3f0203a43f7ce7d246a6764685b700.zip
dev-python/zipp: bump to 2.2.0
Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/zipp')
-rw-r--r--dev-python/zipp/Manifest1
-rw-r--r--dev-python/zipp/zipp-2.2.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/zipp/Manifest b/dev-python/zipp/Manifest
index e72fa1dc3380..010a9c2a202a 100644
--- a/dev-python/zipp/Manifest
+++ b/dev-python/zipp/Manifest
@@ -2,3 +2,4 @@ DIST zipp-0.6.0.tar.gz 10778 BLAKE2B 165ae85f51fe0c0232f6cf2dde70e2d7f8064413c15
DIST zipp-1.0.0.tar.gz 10821 BLAKE2B f5e0476cb0ca01054abc0c56f1a9581a6f537c002791c4a363238555ce9a211fe13114041374c1bfef426544545e3c654e5b0a7e0541c30b775757c43df6d756 SHA512 dbfadfedd30ca4cb31ac4163f367134d96e57405ef00d5f4c19c0af7a141f78487dec29a0ba94975584fcb462d22c8b536bf29c67b7e298368072e897b0e9d82
DIST zipp-2.0.1.tar.gz 12790 BLAKE2B 107079d2cbe73c4d0d7053696181d99636192374eac4598a8f2007b8197c007e90ef39a56d193052d484b36247d73d5712d878ea35d222895e5b3ff21963ba13 SHA512 ac49f0c0aa83398ad0892932b1f067df94e2108691338c80400235053834bcbcb1a58b2b7b5807f398088a09e9d1cb591d94153a2a44ef3ef96506271d817e05
DIST zipp-2.1.0.tar.gz 13758 BLAKE2B 1e1c0e0a7d6b7116c12c8f2af8ba9e807d203920450e1673fc0137ba4f47390ae5fd9c677876b582ed2c91cf33677913ada5fedf20f7c8cdd48c38646d3a4afd SHA512 24829aea6f76bf277e2bef9f039f253d5f7cae5830ca7fb0ad9140ba48ad02bb5848b0f5eccb5e72c5282da1f8e18083b98868aea2ca4f7a41d478a03d012235
+DIST zipp-2.2.0.tar.gz 13850 BLAKE2B 22596eb8428358c70c2ef233a30121c89f327b38941b9b688bf99de4eef1d5748eb6184c5b954cd70d192ee6987966ca487785bdd93e18a0e42d914ae7c96c84 SHA512 33e715d65df93cd9343a663f93e3cb5d120d4bb5ca2cdcabd78e6c19199554351618b685f7b2146f722a4924a9681f94ca129fbb2df37fb0f44358da507828cb
diff --git a/dev-python/zipp/zipp-2.2.0.ebuild b/dev-python/zipp/zipp-2.2.0.ebuild
new file mode 100644
index 000000000000..e49c6c90fb83
--- /dev/null
+++ b/dev-python/zipp/zipp-2.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+# [options.entry_points] is present in setup.cfg but it is empty
+DISTUTILS_USE_SETUPTOOLS=manual
+
+inherit distutils-r1
+
+DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
+HOMEPAGE="https://github.com/jaraco/zipp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-3.4.2[${PYTHON_USEDEP}]
+ test? ( dev-python/jaraco-itertools[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_sphinx docs \
+ ">=dev-python/jaraco-packaging-3.2" \
+ ">=dev-python/rst-linker-1.9"
+
+distutils_enable_tests pytest