summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-24 07:20:22 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-24 08:10:50 +0200
commit6b47149a3712a430272937fa8da120e0821f1fea (patch)
tree468138c526ef7d576cb0d4a01890929c0ce3a73b /dev-python/zope-event/zope-event-5.0.ebuild
parentdev-python/phonenumbers: Bump to 8.13.15 (diff)
downloadgentoo-6b47149a3712a430272937fa8da120e0821f1fea.tar.gz
gentoo-6b47149a3712a430272937fa8da120e0821f1fea.tar.bz2
gentoo-6b47149a3712a430272937fa8da120e0821f1fea.zip
dev-python/zope-event: Bump to 5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zope-event/zope-event-5.0.ebuild')
-rw-r--r--dev-python/zope-event/zope-event-5.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/zope-event/zope-event-5.0.ebuild b/dev-python/zope-event/zope-event-5.0.ebuild
new file mode 100644
index 000000000000..92282d46ec6e
--- /dev/null
+++ b/dev-python/zope-event/zope-event-5.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Event publishing / dispatch, used by Zope Component Architecture"
+HOMEPAGE="
+ https://pypi.org/project/zope.event/
+ https://github.com/zopefoundation/zope.event/
+"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ !dev-python/namespace-zope
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # strip rdep specific to namespaces
+ sed -i -e "/'setuptools'/d" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ distutils_write_namespace zope
+ eunittest
+}