summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-08-16 06:30:35 +0000
committerSam James <sam@gentoo.org>2020-08-18 14:58:55 +0000
commit591ba30ad127b130af8624caf44329d3b4d377ca (patch)
tree00a4abb8933fecbd156901585a671368074b9412 /dev-python/zope-exceptions/zope-exceptions-4.4.ebuild
parentdev-python/zope-i18nmessageid: bump to 5.0.1 (diff)
downloadgentoo-591ba30ad127b130af8624caf44329d3b4d377ca.tar.gz
gentoo-591ba30ad127b130af8624caf44329d3b4d377ca.tar.bz2
gentoo-591ba30ad127b130af8624caf44329d3b4d377ca.zip
dev-python/zope-exceptions: bump to 4.4
* Bump to 4.4, mostly for... * Add Python 3.9 Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/zope-exceptions/zope-exceptions-4.4.ebuild')
-rw-r--r--dev-python/zope-exceptions/zope-exceptions-4.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/zope-exceptions/zope-exceptions-4.4.ebuild b/dev-python/zope-exceptions/zope-exceptions-4.4.ebuild
new file mode 100644
index 000000000000..7e2c645a6e53
--- /dev/null
+++ b/dev-python/zope-exceptions/zope-exceptions-4.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="General purpose exceptions for Zope packages"
+HOMEPAGE="https://pypi.org/project/zope.exceptions/ https://github.com/zopefoundation/zope.exceptions"
+SRC_URI="mirror://pypi/${MY_PN::1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="dev-python/namespace-zope[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/zope-testrunner[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # remove .pth files since dev-python/namespace-zope handles the ns
+ find "${D}" -name '*.pth' -delete || die
+}