summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-04 13:35:49 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-04 13:37:02 +0100
commitbf7339057b1973672fcb467f1e23d4ec0f457acb (patch)
treecd2329efd044dc12a5b50c0907cb841575003e0b /dev-python/zope-testing/zope-testing-4.7-r2.ebuild
parentRevert "dev-python/zope-exceptions: Remove namespace dep" (diff)
downloadgentoo-bf7339057b1973672fcb467f1e23d4ec0f457acb.tar.gz
gentoo-bf7339057b1973672fcb467f1e23d4ec0f457acb.tar.bz2
gentoo-bf7339057b1973672fcb467f1e23d4ec0f457acb.zip
Revert "dev-python/zope-testing: Remove namespace dep"
This reverts commit 3120ce077cf30e17a37b3afa5a78d3798a7a50cf. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zope-testing/zope-testing-4.7-r2.ebuild')
-rw-r--r--dev-python/zope-testing/zope-testing-4.7-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/zope-testing/zope-testing-4.7-r2.ebuild b/dev-python/zope-testing/zope-testing-4.7-r2.ebuild
new file mode 100644
index 000000000000..b9e49909f326
--- /dev/null
+++ b/dev-python/zope-testing/zope-testing-4.7-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Zope testing helpers"
+HOMEPAGE="https://pypi.org/project/zope.testing/ https://github.com/zopefoundation/zope.testing"
+SRC_URI="mirror://pypi/${MY_PN::1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND="dev-python/namespace-zope[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # remove .pth files since dev-python/namespace-zope handles the ns
+ find "${D}" -name '*.pth' -delete || die
+}