summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-07 21:02:15 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-07 21:02:15 +0100
commit061bef5a17b00a52eed4af511b09206870e05e44 (patch)
tree6d13938494e6040571f58df7f0546f68e300adfb /dev-python
parentdev-python/greenlet: Stabilize 2.0.2 ppc, #899122 (diff)
downloadgentoo-061bef5a17b00a52eed4af511b09206870e05e44.tar.gz
gentoo-061bef5a17b00a52eed4af511b09206870e05e44.tar.bz2
gentoo-061bef5a17b00a52eed4af511b09206870e05e44.zip
dev-python/aesara: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/aesara/Manifest3
-rw-r--r--dev-python/aesara/aesara-2.8.10.ebuild115
-rw-r--r--dev-python/aesara/aesara-2.8.11.ebuild113
-rw-r--r--dev-python/aesara/aesara-2.8.9.ebuild102
4 files changed, 0 insertions, 333 deletions
diff --git a/dev-python/aesara/Manifest b/dev-python/aesara/Manifest
index da0d8ce09672..cf843b18008c 100644
--- a/dev-python/aesara/Manifest
+++ b/dev-python/aesara/Manifest
@@ -1,4 +1 @@
-DIST aesara-rel-2.8.10.gh.tar.gz 4342183 BLAKE2B 3e6dcb362d613ce9fb621408d3d7c6f6d3f30e52fe39f484fbe6c9d834d59b428e736b13275d99b204774c719cc532fc42e877685b0639b344fa5b2965dfe602 SHA512 360419a79eb0571d431bb146e5fcf2d63a9c8b40e3ee0a31d7d38aeeceaa47da10ab3f640a4b4011f0a9b28438f20a0feb3ea64d07289d0e9513cb32d066820b
-DIST aesara-rel-2.8.11.gh.tar.gz 4680093 BLAKE2B 29409c49d2d31e9a51d0a2d09a50b85ae3195df7fdb2722abcefcdf36dcd429f4e3b5c483e4bd8a0789eeefdcff3ea8f057583e69cd7c216aa6c5292dd3630c3 SHA512 58298b9cb94e4e9eb025f151de7352c6c8b91e8946ddb98384dcae72977107607e101ef42c63a44d75020b40175041e1b7fdd030b733d80b6a102a265532d337
DIST aesara-rel-2.8.12.gh.tar.gz 4582575 BLAKE2B d212e41fd22b54335bcc6f7a744d51113b1cfbad011480eabfde1b72cef5955ce019f2ee2a821d4cea22aa4340a2537156e3f4a5a1962ae0f23107d20df3d70a SHA512 c65e63efa1d6e9de0df6db6f96226d6f830198626a3dc7e77a977e3260ab276745b9c8ae5fa9ea48edb9aee9d88c8181e7a7e19aaa49e51290e4df619e227bbf
-DIST aesara-rel-2.8.9.gh.tar.gz 4351952 BLAKE2B ffdc3d33caba5cf5edd3dd15e62cd295dd23f944ac6d76461e9e43717a4126669391dadfee51c6117911dc4236e8787d3e9ab712a0fcbd1dcb137e64f9f994c4 SHA512 3fb4374899ab71366961a07c750f594505467cdab01b6851b36d1dd924b816117ebe488a6cae548650df393c8447de69e21ce2cf6eafe34e951b98f27c3a4f6c
diff --git a/dev-python/aesara/aesara-2.8.10.ebuild b/dev-python/aesara/aesara-2.8.10.ebuild
deleted file mode 100644
index ecc99c59864d..000000000000
--- a/dev-python/aesara/aesara-2.8.10.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-# A whole bunch of test failures with 3.11
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit distutils-r1 multiprocessing optfeature
-
-MY_P=aesara-rel-${PV}
-DESCRIPTION="Library for operating on mathematical expressions with multi-dimensional arrays"
-HOMEPAGE="
- https://github.com/aesara-devs/aesara/
- https://pypi.org/project/aesara/
-"
-SRC_URI="
- https://github.com/aesara-devs/aesara/archive/rel-${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
-
-RDEPEND="
- dev-python/cons[${PYTHON_USEDEP}]
- dev-python/etuples[${PYTHON_USEDEP}]
- dev-python/logical-unification[${PYTHON_USEDEP}]
- dev-python/minikanren[${PYTHON_USEDEP}]
- dev-python/filelock[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/aesara-2.6.5-compiledir-tid.patch
- "${FILESDIR}"/aesara-2.8.10-fix-tuple.patch
-)
-
-distutils_enable_sphinx doc 'dev-python/sphinx-rtd-theme'
-distutils_enable_tests pytest
-
-src_prepare() {
- # do not claim "bin" package (sic!)
- rm bin/__init__.py || die
- distutils-r1_src_prepare
-
- export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # speed tests are unreliable
- tests/scan/test_basic.py::test_speed
- tests/scan/test_basic.py::test_speed_rnn
- tests/scan/test_basic.py::test_speed_batchrnn
- tests/link/test_vm.py::test_speed
- tests/link/test_vm.py::test_speed_lazy
- tests/tensor/test_gc.py::test_merge_opt_runtime
-
- # rounding problem?
- # https://github.com/aesara-devs/aesara/issues/477
- tests/tensor/test_math_scipy.py::TestGammaUBroadcast::test_good
- tests/tensor/test_math_scipy.py::TestGammaUInplaceBroadcast::test_good
-
- # Deprecation warning causes unexpected additional output
- tests/tensor/test_basic.py::TestLongTensor::test_fit_int64
-
- # dunno
- tests/tensor/test_elemwise.py::TestDimShuffle::test_memory_leak
- tests/tensor/signal/test_pool.py::TestDownsampleFactorMax::test_DownsampleFactorMaxGradGrad_grad
-
- # TODO
- tests/link/c/test_op.py::test_ExternalCOp_c_code_cache_version
- tests/sparse/sandbox/test_sp.py::TestSP::test_multilayer_conv
- tests/sparse/sandbox/test_sp.py::TestSP::test_maxpool
-
- # TODO: Package pytest-benchmark
- tests/scan/test_basic.py::TestExamples::test_reordering
- tests/scan/test_basic.py::TestExamples::test_scan_as_tensor_on_gradients
- tests/scan/test_basic.py::TestExamples::test_multiple_outs_taps
- tests/scan/test_rewriting.py::TestPushOutAddScan::test_pregreedy_optimizer
- tests/scan/test_rewriting.py::TestSaveMem::test_savemem_opt
- tests/scan/test_basic.py::test_cython_performance
- )
- local EPYTEST_IGNORE=(
- # we do not package jax or numba
- tests/link/jax
- tests/link/numba
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x AESARA_FLAGS="cxx=${CXX}"
- AESARA_FLAGS+=",config.gcc__cxxflags=\"${CXXFLAGS}\""
- AESARA_FLAGS+=',compiledir_format="compiledir_%(thread_id)s"'
-
- epytest -p xdist.plugin -n "$(makeopts_jobs)"
- # clean up the compiledir, as it can grow pretty large
- rm -r "${HOME}"/.aesara || die
-}
-
-pkg_postinst() {
- optfeature "GPU code generation/execution on NVIDIA gpus" dev-util/nvidia-cuda-toolkit
- optfeature "GPU/CPU code generation on CUDA and OpenCL devices" dev-libs/libgpuarray dev-python/pycuda
-}
diff --git a/dev-python/aesara/aesara-2.8.11.ebuild b/dev-python/aesara/aesara-2.8.11.ebuild
deleted file mode 100644
index e964e1962314..000000000000
--- a/dev-python/aesara/aesara-2.8.11.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit distutils-r1 multiprocessing optfeature
-
-MY_P=aesara-rel-${PV}
-DESCRIPTION="Library for operating on mathematical expressions with multi-dimensional arrays"
-HOMEPAGE="
- https://github.com/aesara-devs/aesara/
- https://pypi.org/project/aesara/
-"
-SRC_URI="
- https://github.com/aesara-devs/aesara/archive/rel-${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
-
-RDEPEND="
- dev-python/cons[${PYTHON_USEDEP}]
- dev-python/etuples[${PYTHON_USEDEP}]
- dev-python/logical-unification[${PYTHON_USEDEP}]
- dev-python/minikanren[${PYTHON_USEDEP}]
- dev-python/filelock[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/hatch-vcs[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/aesara-2.6.5-compiledir-tid.patch
- "${FILESDIR}"/aesara-2.8.10-fix-tuple.patch
-)
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # do not claim "bin" package (sic!)
- rm bin/__init__.py || die
- distutils-r1_src_prepare
-
- export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # speed tests are unreliable
- tests/scan/test_basic.py::test_speed
- tests/scan/test_basic.py::test_speed_rnn
- tests/scan/test_basic.py::test_speed_batchrnn
- tests/link/test_vm.py::test_speed
- tests/link/test_vm.py::test_speed_lazy
- tests/tensor/test_gc.py::test_merge_opt_runtime
-
- # rounding problem?
- # https://github.com/aesara-devs/aesara/issues/477
- tests/tensor/test_math_scipy.py::TestGammaUBroadcast::test_good
- tests/tensor/test_math_scipy.py::TestGammaUInplaceBroadcast::test_good
-
- # Deprecation warning causes unexpected additional output
- tests/tensor/test_basic.py::TestLongTensor::test_fit_int64
-
- # dunno
- tests/tensor/test_elemwise.py::TestDimShuffle::test_memory_leak
- tests/tensor/signal/test_pool.py::TestDownsampleFactorMax::test_DownsampleFactorMaxGradGrad_grad
-
- # TODO
- tests/link/c/test_op.py::test_ExternalCOp_c_code_cache_version
- tests/sparse/sandbox/test_sp.py::TestSP::test_multilayer_conv
- tests/sparse/sandbox/test_sp.py::TestSP::test_maxpool
-
- # TODO: Package pytest-benchmark
- tests/scan/test_basic.py::TestExamples::test_reordering
- tests/scan/test_basic.py::TestExamples::test_scan_as_tensor_on_gradients
- tests/scan/test_basic.py::TestExamples::test_multiple_outs_taps
- tests/scan/test_rewriting.py::TestPushOutAddScan::test_pregreedy_optimizer
- tests/scan/test_rewriting.py::TestSaveMem::test_savemem_opt
- tests/scan/test_basic.py::test_cython_performance
- )
- local EPYTEST_IGNORE=(
- # we do not package jax or numba
- tests/link/jax
- tests/link/numba
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x AESARA_FLAGS="cxx=${CXX}"
- AESARA_FLAGS+=",config.gcc__cxxflags=\"${CXXFLAGS}\""
- AESARA_FLAGS+=',compiledir_format="compiledir_%(thread_id)s"'
-
- epytest -p xdist.plugin -n "$(makeopts_jobs)"
- # clean up the compiledir, as it can grow pretty large
- rm -r "${HOME}"/.aesara || die
-}
-
-pkg_postinst() {
- optfeature "GPU code generation/execution on NVIDIA gpus" dev-util/nvidia-cuda-toolkit
- optfeature "GPU/CPU code generation on CUDA and OpenCL devices" dev-libs/libgpuarray dev-python/pycuda
-}
diff --git a/dev-python/aesara/aesara-2.8.9.ebuild b/dev-python/aesara/aesara-2.8.9.ebuild
deleted file mode 100644
index 5022ff79eae2..000000000000
--- a/dev-python/aesara/aesara-2.8.9.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit distutils-r1 multiprocessing optfeature
-
-MY_P=aesara-rel-${PV}
-DESCRIPTION="Library for operating on mathematical expressions with multi-dimensional arrays"
-HOMEPAGE="
- https://github.com/aesara-devs/aesara/
- https://pypi.org/project/aesara/
-"
-SRC_URI="
- https://github.com/aesara-devs/aesara/archive/rel-${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv x86"
-
-RDEPEND="
- dev-python/cons[${PYTHON_USEDEP}]
- dev-python/etuples[${PYTHON_USEDEP}]
- dev-python/logical-unification[${PYTHON_USEDEP}]
- dev-python/minikanren[${PYTHON_USEDEP}]
- dev-python/filelock[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- >=dev-python/setuptools-48.0.0[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/aesara-2.6.5-compiledir-tid.patch
-)
-
-distutils_enable_sphinx doc 'dev-python/sphinx-rtd-theme'
-distutils_enable_tests pytest
-
-src_prepare() {
- # do not claim "bin" package (sic!)
- rm bin/__init__.py || die
- sed -e 's/find:/find_namespace:/' \
- -e '/exclude =/a\ doc*' \
- -i setup.cfg || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # speed tests are unreliable
- tests/scan/test_basic.py::test_speed
- tests/scan/test_basic.py::test_speed_rnn
- tests/scan/test_basic.py::test_speed_batchrnn
- tests/link/test_vm.py::test_speed
- tests/link/test_vm.py::test_speed_lazy
- tests/tensor/test_gc.py::test_merge_opt_runtime
-
- # rounding problem?
- # https://github.com/aesara-devs/aesara/issues/477
- tests/tensor/test_math_scipy.py::TestGammaUBroadcast::test_good
- tests/tensor/test_math_scipy.py::TestGammaUInplaceBroadcast::test_good
-
- # dunno
- tests/tensor/test_elemwise.py::TestDimShuffle::test_memory_leak
-
- # TODO
- tests/link/c/test_op.py::test_ExternalCOp_c_code_cache_version
- tests/sparse/sandbox/test_sp.py::TestSP::test_multilayer_conv
- tests/sparse/sandbox/test_sp.py::TestSP::test_maxpool
- )
- local EPYTEST_IGNORE=(
- # we do not package jax or numba
- tests/link/jax
- tests/link/numba
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x AESARA_FLAGS="cxx=${CXX}"
- AESARA_FLAGS+=",config.gcc__cxxflags=\"${CXXFLAGS}\""
- AESARA_FLAGS+=',compiledir_format="compiledir_%(thread_id)s"'
-
- epytest -p xdist.plugin -n "$(makeopts_jobs)"
- # clean up the compiledir, as it can grow pretty large
- rm -r "${HOME}"/.aesara || die
-}
-
-pkg_postinst() {
- optfeature "GPU code generation/execution on NVIDIA gpus" dev-util/nvidia-cuda-toolkit dev-util/nvidia-cuda-sdk
- optfeature "GPU/CPU code generation on CUDA and OpenCL devices" dev-libs/libgpuarray dev-python/pycuda
-}