summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-27 07:50:00 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-27 08:19:40 +0100
commit208f8758eae6c9613b008455e3f40afdfdfc83c9 (patch)
treeb247ae6385d24575af4e88a8c305e0d7c53bd9f0 /dev-python
parentdev-python/setuptools: Bump to 59.3.0 (diff)
downloadgentoo-208f8758eae6c9613b008455e3f40afdfdfc83c9.tar.gz
gentoo-208f8758eae6c9613b008455e3f40afdfdfc83c9.tar.bz2
gentoo-208f8758eae6c9613b008455e3f40afdfdfc83c9.zip
dev-python/fsspec: Bump to 2021.11.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/fsspec/Manifest1
-rw-r--r--dev-python/fsspec/fsspec-2021.11.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/fsspec/Manifest b/dev-python/fsspec/Manifest
index 99d0af38f1fb..2f4a333e4470 100644
--- a/dev-python/fsspec/Manifest
+++ b/dev-python/fsspec/Manifest
@@ -1,2 +1,3 @@
DIST filesystem_spec-2021.10.1.tar.gz 315068 BLAKE2B c9be13ba8a2821274335fb924e91904640f4505a7e639211c7b6701f63f7dcddae018c15933b291d4f4d9f2ea451136e09ede637d615985889b565a12ac93665 SHA512 2f89a24b5491e15d3b3d9a2e6307c6d4a0db61848ad5e9324f4e234d4204e3a1f78b00a50b26f6fe90d657df6700aa23cb76f5df996b29dd880b7c8677d21382
DIST filesystem_spec-2021.11.0.tar.gz 322885 BLAKE2B 5bd751b73fdc9d2c1568e1b769cb188ac3937148a83b28a412038924339b3a2443ec783ee730ec29bf585c33aadd46dbe295a08d4cbea679119c3119e75190b1 SHA512 fc742548cd8404ce90a673e2df37cb0d06add639fc3b5bb4e1c80b7a0d5a6c815196ab19e65c207651ba8087bd1d742da0c60f5655b7fd65ef5d1883fac4417b
+DIST filesystem_spec-2021.11.1.tar.gz 325020 BLAKE2B a5d1a483bb446a6241e34d4d6f505b46657d837209ff259c6638843205b606a4f6823b9b2510c88fea2e4adec01aabd36df1ceb188444b8786b4acb4e34e33f1 SHA512 a7985e46d7ac989908a8d5bfdb47baa49d84e220fe16774db029d25408cf9f3d956ab468bb351fc956ca388b8e7d0054151fa33e380d50f0e1d8303bbed15890
diff --git a/dev-python/fsspec/fsspec-2021.11.1.ebuild b/dev-python/fsspec/fsspec-2021.11.1.ebuild
new file mode 100644
index 000000000000..c5f98d04c9e8
--- /dev/null
+++ b/dev-python/fsspec/fsspec-2021.11.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P=filesystem_spec-${PV}
+DESCRIPTION="A specification that python filesystems should adhere to"
+HOMEPAGE="https://github.com/fsspec/filesystem_spec/
+ https://pypi.org/project/fsspec/"
+SRC_URI="
+ https://github.com/fsspec/filesystem_spec/archive/${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="
+ dev-python/versioneer[${PYTHON_USEDEP}]
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+distutils_enable_tests pytest
+
+src_test() {
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ distutils-r1_src_test
+}
+
+EPYTEST_DESELECT=(
+ fsspec/tests/test_spec.py::test_find
+)
+
+EPYTEST_IGNORE=(
+ # sftp and smb require server started via docker
+ fsspec/implementations/tests/test_dbfs.py
+ fsspec/implementations/tests/test_sftp.py
+ fsspec/implementations/tests/test_smb.py
+)