summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-18 19:53:39 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-18 20:06:14 +0100
commit25762ce45efa8e45690286f4ff80d6f6ff94e64f (patch)
tree8ef077ea2c7aebe3f455df225c92f0f315eb3428 /dev-python
parentdev-python/nototools: Remove old (diff)
downloadgentoo-25762ce45efa8e45690286f4ff80d6f6ff94e64f.tar.gz
gentoo-25762ce45efa8e45690286f4ff80d6f6ff94e64f.tar.bz2
gentoo-25762ce45efa8e45690286f4ff80d6f6ff94e64f.zip
dev-python/python-language-server: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-language-server/Manifest1
-rw-r--r--dev-python/python-language-server/python-language-server-0.36.1.ebuild70
2 files changed, 0 insertions, 71 deletions
diff --git a/dev-python/python-language-server/Manifest b/dev-python/python-language-server/Manifest
index 925cd99e9a40..153f27d97f38 100644
--- a/dev-python/python-language-server/Manifest
+++ b/dev-python/python-language-server/Manifest
@@ -1,2 +1 @@
-DIST python-language-server-0.36.1.tar.gz 74524 BLAKE2B 3337bf4c91204302b26b2496bc79ae6e0c18143f89ef97861dd91760b27406eba8fc9895a2f00c5c2de3a990eeb8ba29ba10319262466a42b1fb362af809060f SHA512 4a8150cf1334e9b2085e9b4ca7165404f30127339bd0fe8db229924c67933bfcd7827a875136b1694a82d4f447255862df116bc6d74a51df8e1ed82a6875914b
DIST python-language-server-0.36.2.tar.gz 74499 BLAKE2B 0bf950e236f8f898c3158afc2b3355948340639b607f474654b0334d484170a210b6e81c7508f12368223ae9915ccf19f76a1bcde41503230d8c008ba0818b47 SHA512 ee909d9332ef76c616d727ebfa36e80fd03ab57df8fc57265de21f0105cc0b64a518b2a8a582f88364d03a7d2a66e1030bcf5b3452ad3a891a3141da9b338373
diff --git a/dev-python/python-language-server/python-language-server-0.36.1.ebuild b/dev-python/python-language-server/python-language-server-0.36.1.ebuild
deleted file mode 100644
index 7a34f6296f50..000000000000
--- a/dev-python/python-language-server/python-language-server-0.36.1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8} )
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="An implementation of the Language Server Protocol for Python"
-HOMEPAGE="https://github.com/palantir/python-language-server"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-
-BDEPEND="dev-python/versioneer[${PYTHON_USEDEP}]
- test? (
- dev-python/autopep8[${PYTHON_USEDEP}]
- dev-python/flaky[${PYTHON_USEDEP}]
- >=dev-python/flake8-3.8.0[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- >=dev-python/mccabe-0.6.0[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- >=dev-python/pycodestyle-2.6.0[${PYTHON_USEDEP}]
- <dev-python/pycodestyle-2.7.0[${PYTHON_USEDEP}]
- >=dev-python/pydocstyle-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/pyflakes-2.2.0[${PYTHON_USEDEP}]
- <dev-python/pyflakes-2.3.0[${PYTHON_USEDEP}]
- >=dev-python/pylint-2.5.0[${PYTHON_USEDEP}]
- dev-python/QtPy[gui,testlib,${PYTHON_USEDEP}]
- >=dev-python/rope-0.10.5[${PYTHON_USEDEP}]
- dev-python/yapf[${PYTHON_USEDEP}]
-)"
-
-RDEPEND="
- >=dev-python/jedi-0.17.2[${PYTHON_USEDEP}]
- <dev-python/jedi-0.18.0[${PYTHON_USEDEP}]
- dev-python/pluggy[${PYTHON_USEDEP}]
- >=dev-python/python-jsonrpc-server-0.4.0[${PYTHON_USEDEP}]
- >=dev-python/ujson-3[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # remove pytest-cov dep
- sed -i -e '0,/addopts/I!d' setup.cfg || die
-
- distutils-r1_python_prepare_all
-}
-
-pkg_postinst() {
- elog "To get additional features, optional runtime dependencies may be installed:"
- optfeature "Automatically formats Python code to conform to the PEP 8 style guide" dev-python/autopep8
- optfeature "A wrapper around PyFlakes, pep8 & mccabe" dev-python/flake8
- optfeature "flake8 plugin: McCabe complexity checker" dev-python/mccabe
- optfeature "Python style guide checker (fka pep8)" dev-python/pycodestyle
- optfeature "Python docstring style checker" dev-python/pydocstyle
- optfeature "Passive checker for Python programs" dev-python/pyflakes
- optfeature "Python code static checker" dev-python/pylint
- optfeature "Python refactoring library" dev-python/rope
- optfeature "A formatter for Python files" dev-python/yapf
-}