summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-04 06:11:44 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-04 06:48:04 +0100
commit2b7f9ecd3f5b9f3b26402b744920a6bdda529ffa (patch)
tree2d6a76eb3227c841b2d44046d9070bd38076860c /dev-python
parentdev-python/autopep8: Bump to 2.0.2 (diff)
downloadgentoo-2b7f9ecd3f5b9f3b26402b744920a6bdda529ffa.tar.gz
gentoo-2b7f9ecd3f5b9f3b26402b744920a6bdda529ffa.tar.bz2
gentoo-2b7f9ecd3f5b9f3b26402b744920a6bdda529ffa.zip
dev-python/APScheduler: Bump to 3.10.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/APScheduler/APScheduler-3.10.1.ebuild64
-rw-r--r--dev-python/APScheduler/Manifest1
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/APScheduler/APScheduler-3.10.1.ebuild b/dev-python/APScheduler/APScheduler-3.10.1.ebuild
new file mode 100644
index 000000000000..28f2bd56e4f2
--- /dev/null
+++ b/dev-python/APScheduler/APScheduler-3.10.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="In-process task scheduler with Cron-like capabilities"
+HOMEPAGE="
+ https://github.com/agronholm/apscheduler/
+ https://pypi.org/project/APScheduler/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# imports pkg_resources
+RDEPEND="
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/tzlocal-4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/sqlalchemy-1.4[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-tornado[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ # disable test fixtures using external servers (mongodb, redis...)
+ # these fixtures are using markers in git master, so the patch
+ # should be no longer necessary with next major bump
+ "${FILESDIR}"/APScheduler-3.8.1-external-server-tests.patch
+)
+
+EPYTEST_DESELECT=(
+ tests/test_jobstores.py::test_repr_mongodbjobstore
+ tests/test_jobstores.py::test_repr_redisjobstore
+ tests/test_jobstores.py::test_repr_zookeeperjobstore
+)
+
+python_prepare_all() {
+ # suppress setuptools warning #797751
+ sed -e 's|^upload-dir|upload_dir|' -i setup.cfg || die
+ sed -e '/addopts/d' -i setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -p tornado
+}
diff --git a/dev-python/APScheduler/Manifest b/dev-python/APScheduler/Manifest
index b1ece2737e82..481c47eadf16 100644
--- a/dev-python/APScheduler/Manifest
+++ b/dev-python/APScheduler/Manifest
@@ -1,2 +1,3 @@
DIST APScheduler-3.10.0.tar.gz 100353 BLAKE2B 0d5c25641410161b15bd337661c15443b1034c85d5fa770b4603352c86f517d0ebb9713ac514a2efe1ec5d77f086fbecfb2c39bbf6e41ec6666cfcbb619dd3cb SHA512 ba44be82b10bac899b631b32d78ecc9303955241d2e2b7597282bd914726af3cf406bd3c6e0285f2a9b1737288453075107f317118ae1240de9e15f36290c979
+DIST APScheduler-3.10.1.tar.gz 100376 BLAKE2B 6b5aed1197ec6cdcf2c82d73c2809d9fd304401ad5ac482cdd0dfc310356248b9ba5f0cf611f5484f4098c92d7b6f8b81f117fe5fd645b5d20ba0fbb7f1d6c97 SHA512 bba68c97d2e7cda6503a8471a61bf57c11b9c8b6dde4d1da65f7d134bf72f631b3f70815ac7db3f75313833c780ee6ded0b8d0e1c9a86e05e741788bcd041008
DIST APScheduler-3.9.1.tar.gz 100567 BLAKE2B a31e2591c47d451e95a982b4d85a70ee9a33bf2370a70e0e1ba2a8e31ae718d5853aad6242cbd8f90dc5bc6912af3ea96270e9f514c3903d041af450c1d8ead5 SHA512 901e04140dc9af3b67887cd3200131cc4121cad71b7ca4afe7cc0adf1a58cebb02eee5abed1f97fc95fe9fef843d00cd6611ab3fbff8ace9247894d6f0720dff