summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-27 10:35:05 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-27 14:26:56 +0200
commit30fb8e78eaa414bf0b486e5c21d9028f1c3dd5b1 (patch)
treea630c38ac199e2280da6f511507d22b8047e9ebc /dev-python
parentsys-devel/clang: Modernize (diff)
downloadgentoo-30fb8e78eaa414bf0b486e5c21d9028f1c3dd5b1.tar.gz
gentoo-30fb8e78eaa414bf0b486e5c21d9028f1c3dd5b1.tar.bz2
gentoo-30fb8e78eaa414bf0b486e5c21d9028f1c3dd5b1.zip
dev-python/clang-python: Modernize
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/clang-python/clang-python-15.0.0.9999.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/dev-python/clang-python/clang-python-15.0.0.9999.ebuild b/dev-python/clang-python/clang-python-15.0.0.9999.ebuild
index fb6456619641..9e000ace36bf 100644
--- a/dev-python/clang-python/clang-python-15.0.0.9999.ebuild
+++ b/dev-python/clang-python/clang-python-15.0.0.9999.ebuild
@@ -13,17 +13,23 @@ LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
KEYWORDS=""
IUSE="test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
# The module is opening libclang.so directly, and doing some blasphemy
# on top of it.
-RDEPEND="
+DEPEND="
>=sys-devel/clang-${PV}:*
!sys-devel/llvm:0[clang(-),python(-)]
!sys-devel/clang:0[python(-)]
- ${PYTHON_DEPS}"
-DEPEND="${RDEPEND}"
+"
+RDEPEND="
+ ${DEPEND}
+ ${PYTHON_DEPS}
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+"
LLVM_COMPONENTS=( clang/bindings/python )
llvm.org_set_globals