summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-12 19:00:17 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-12 19:34:02 +0200
commit36c775339d98c48a154bb3759a2f7e7e6936716d (patch)
tree691eeabdc79ec83b84d8ab067c8c3e4b93bf8ac2 /dev-python
parentdev-python/sphinx-autodoc-typehints: Bump to 1.18.0 (diff)
downloadgentoo-36c775339d98c48a154bb3759a2f7e7e6936716d.tar.gz
gentoo-36c775339d98c48a154bb3759a2f7e7e6936716d.tar.bz2
gentoo-36c775339d98c48a154bb3759a2f7e7e6936716d.zip
dev-python/python-lsp-black: Bump to 1.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-lsp-black/Manifest1
-rw-r--r--dev-python/python-lsp-black/python-lsp-black-1.2.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/python-lsp-black/Manifest b/dev-python/python-lsp-black/Manifest
index c5610989d9b9..3647d928ca82 100644
--- a/dev-python/python-lsp-black/Manifest
+++ b/dev-python/python-lsp-black/Manifest
@@ -1 +1,2 @@
DIST python-lsp-black-1.2.0.gh.tar.gz 9226 BLAKE2B a9efe698c32ac86060f360e1d1129620783d0dd1588cf16b6f96a4f805845d5c94e862b265d63643e877afc68916ad0fbbe922fc0c17e224ea08f61756a3fb41 SHA512 b5f999b0e02abc63dc194a2973f028aa5f74b3110d0ac35e6aefb45a4260bf3fb5b1f142f71a85feec431765af98409977a47039d28a79cfac5746cc677794c7
+DIST python-lsp-black-1.2.1.gh.tar.gz 9355 BLAKE2B f9c70ff07d9dfa31e3af919143deb8a49f43269469e8c64525f514624f4db67636da8254dae5274685ba2d883c8ddfd6dd9cb99981a337d7837d4007f15af11c SHA512 289b8f3642ed806409671d25e32997fb473720d0abd642c58c07d8c894831fa00f56dbc39e7d0fc8d98cad7de9f95ebdb6a0f637b8b4bbcc2a0716690feb647e
diff --git a/dev-python/python-lsp-black/python-lsp-black-1.2.1.ebuild b/dev-python/python-lsp-black/python-lsp-black-1.2.1.ebuild
new file mode 100644
index 000000000000..e6006b0f3e59
--- /dev/null
+++ b/dev-python/python-lsp-black/python-lsp-black-1.2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Black plugin for the Python LSP Server"
+HOMEPAGE="
+ https://github.com/python-lsp/python-lsp-black/
+ https://pypi.org/project/python-lsp-black/
+"
+SRC_URI="
+ https://github.com/python-lsp/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/python-lsp-server-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/black-22.3.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/toml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest