summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-03 15:13:57 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-03 15:13:57 +0100
commit442a419463a8fcc22e794d3a24544e044e16df0a (patch)
tree98dbfb81c978465290fd8559a6936a7738a66217 /dev-python
parentapp-i18n/ibus-table: drop old (diff)
downloadgentoo-442a419463a8fcc22e794d3a24544e044e16df0a.tar.gz
gentoo-442a419463a8fcc22e794d3a24544e044e16df0a.tar.bz2
gentoo-442a419463a8fcc22e794d3a24544e044e16df0a.zip
dev-python/pymssql: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pymssql/Manifest1
-rw-r--r--dev-python/pymssql/files/pymssql-2.1.3-DBVERSION_80.patch13
-rw-r--r--dev-python/pymssql/pymssql-2.1.3.ebuild47
3 files changed, 0 insertions, 61 deletions
diff --git a/dev-python/pymssql/Manifest b/dev-python/pymssql/Manifest
index 1178559ead7a..22e69da2c454 100644
--- a/dev-python/pymssql/Manifest
+++ b/dev-python/pymssql/Manifest
@@ -1,2 +1 @@
-DIST pymssql-2.1.3.tar.gz 897987 BLAKE2B e105dd8d5dbbad5de566b9179f799ad66eb420f60464e8061470b1abb6ecf38f35ad7992ded40f2cd62c76a8e04255eb647e30df5c9bc4059334a1d5d4677e73 SHA512 a659cb8f077ddbe5e8de0b9b118d8bcc0c87128c0be4ff14343983e7029594e63ba6fb8a88992dc1f058df3c1ebbbd69cf371bf95a0918954cd0cec14c1cb5cb
DIST pymssql-2.1.5.tar.gz 167928 BLAKE2B c94fc29fa9d83627dbee05095a7c0d6e4e2d42ac34b0e6801bbc757d89728aee409c98519d6e8bfe8d5009f06f88bd23a3e62c050f2c964cb7139bdd3185a0b5 SHA512 7cc7336d4c2fcb7c3958fb3127801e3505fd93259d1aaef40a67941ef5aa519e285cdb04fd378c9712f29b0f8a25ce1747a4a8dc21ec57b004c9f0ceb8f5afab
diff --git a/dev-python/pymssql/files/pymssql-2.1.3-DBVERSION_80.patch b/dev-python/pymssql/files/pymssql-2.1.3-DBVERSION_80.patch
deleted file mode 100644
index 9d72a9817358..000000000000
--- a/dev-python/pymssql/files/pymssql-2.1.3-DBVERSION_80.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/_mssql.pyx
-+++ b/_mssql.pyx
-@@ -34,6 +34,10 @@ DEF EXCOMM = 9
- # Provide constants missing in FreeTDS 0.82 so that we can build against it
- DEF DBVERSION_71 = 5
- DEF DBVERSION_72 = 6
-+# See /usr/include/sybdb.h - DBVERSION_80 is not defined in FreeTDS 1.00.13
-+# (cf. http://www.freetds.org/userguide/choosingtdsprotocol.htm)
-+# 8.0 was actually 7.1 so set it to the same value
-+DEF DBVERSION_80 = 5
-
- ROW_FORMAT_TUPLE = 1
- ROW_FORMAT_DICT = 2
diff --git a/dev-python/pymssql/pymssql-2.1.3.ebuild b/dev-python/pymssql/pymssql-2.1.3.ebuild
deleted file mode 100644
index 0e1da52fced0..000000000000
--- a/dev-python/pymssql/pymssql-2.1.3.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Simple MSSQL python extension module"
-HOMEPAGE="https://www.pymssql.org/ https://pypi.org/project/pymssql/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~hppa ~ia64 ppc ppc64 ~s390 sparc x86"
-IUSE="test"
-
-# tests need a running instance of freetds
-RESTRICT="test"
-
-RDEPEND=">=dev-db/freetds-0.63[mssql]"
-DEPEND="
- ${RDEPEND}
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.1.3-DBVERSION_80.patch
- "${FILESDIR}"/${PN}-2.1.3-remove-setuptools_git.patch
-)
-
-python_prepare_all() {
- # delete stale cython .c file
- # this can cause issues with the patches
- rm {_mssql,pymssql}.c || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- py.test -v || die "Tests fail with ${EPYTHON}"
-}