summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-01 18:58:22 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-01 19:32:52 +0100
commit48b85361315dc73c61a1b2c04384adb8aec41e9f (patch)
treef72ec00c0605e297e10b6e3a56080a49ad0f394d /dev-python
parentdev-python/python-cinderclient: Bump to 9.5.0 (diff)
downloadgentoo-48b85361315dc73c61a1b2c04384adb8aec41e9f.tar.gz
gentoo-48b85361315dc73c61a1b2c04384adb8aec41e9f.tar.bz2
gentoo-48b85361315dc73c61a1b2c04384adb8aec41e9f.zip
dev-python/python-glanceclient: Bump to 4.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-glanceclient/Manifest1
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-4.5.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/python-glanceclient/Manifest b/dev-python/python-glanceclient/Manifest
index f2796d6586af..1b1cc611a244 100644
--- a/dev-python/python-glanceclient/Manifest
+++ b/dev-python/python-glanceclient/Manifest
@@ -1 +1,2 @@
DIST python-glanceclient-4.4.0.tar.gz 205612 BLAKE2B 8a1e31eb8dbefe4b08e945377bb190264332cd01066b96ec061e8839a45294ed6cf5ab08fd89d97b57bc072987ce04d19f94a887d5e8eaa10760d996058122bf SHA512 31d2994fef3298f790a3ec268b26d432602a6b73265277e961ff2b47df2a84028253da8b2090193e1e65c55ab6e4b40413a16d01a653b90cae926545ea4097ae
+DIST python-glanceclient-4.5.0.tar.gz 205909 BLAKE2B 5e48abd2c869d4f3a0bfbfc593950754fd165bd36a98bc4358d88a1b64f6892b6633f10421999733c014fe8f1664d1181b5019739997139c1ef5d604194cfda8 SHA512 141f03fa55012981214283e961c4d4020a2fa4dc87b7cbc323d87c536b88e98f4798b59d83dc627a5846c5437fdac963fb34a3db444c20410a01441bf5838fa7
diff --git a/dev-python/python-glanceclient/python-glanceclient-4.5.0.ebuild b/dev-python/python-glanceclient/python-glanceclient-4.5.0.ebuild
new file mode 100644
index 000000000000..6930cb7e8b95
--- /dev/null
+++ b/dev-python/python-glanceclient/python-glanceclient-4.5.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A client for the OpenStack Glance API"
+HOMEPAGE="
+ https://opendev.org/openstack/python-glanceclient/
+ https://github.com/openstack/python-glanceclient/
+ https://pypi.org/project/python-glanceclient/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/keystoneauth1-3.6.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/warlock-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/tempest[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ <dev-python/urllib3-2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ # functional tests require cloud instance access
+ eunittest -b glanceclient/tests/unit
+}