summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-10 09:51:46 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-10 10:59:52 +0200
commit4cd2feab7d902447663a239b7daec9e6ace10227 (patch)
tree1eb009e7febb6ab9b30a1a39ee39473e35784de3 /dev-python
parentdev-java/slf4j-api: removed obsolete 1.7.30 (diff)
downloadgentoo-4cd2feab7d902447663a239b7daec9e6ace10227.tar.gz
gentoo-4cd2feab7d902447663a239b7daec9e6ace10227.tar.bz2
gentoo-4cd2feab7d902447663a239b7daec9e6ace10227.zip
dev-python/url-normalize: New dep of dev-python/requests-cache
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/url-normalize/Manifest1
-rw-r--r--dev-python/url-normalize/metadata.xml11
-rw-r--r--dev-python/url-normalize/url-normalize-1.4.3.ebuild30
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/url-normalize/Manifest b/dev-python/url-normalize/Manifest
new file mode 100644
index 000000000000..1d11186b719f
--- /dev/null
+++ b/dev-python/url-normalize/Manifest
@@ -0,0 +1 @@
+DIST url-normalize-1.4.3.gh.tar.gz 8478 BLAKE2B 2f15a597642626653c96f378b67794819645918473d17faad18187abe35bf7892b11c0bc78451e78f1146389beb3a6470fb3ea1610e60157fee7fbadd9863614 SHA512 46eaa1753b37e89d56cb19818144a7cf5b38653811720eb506732c35bb3732ef0c556420b22a9ee2c08e70e5b408aab7f44cea5e15d1ebe3d717c0c77706bfb8
diff --git a/dev-python/url-normalize/metadata.xml b/dev-python/url-normalize/metadata.xml
new file mode 100644
index 000000000000..601aeb3c280e
--- /dev/null
+++ b/dev-python/url-normalize/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">niksite/url-normalize</remote-id>
+ <remote-id type="pypi">url-normalize</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/url-normalize/url-normalize-1.4.3.ebuild b/dev-python/url-normalize/url-normalize-1.4.3.ebuild
new file mode 100644
index 000000000000..79a18fe1ba92
--- /dev/null
+++ b/dev-python/url-normalize/url-normalize-1.4.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="URL normalization for Python"
+HOMEPAGE="
+ https://github.com/niksite/url-normalize/
+ https://pypi.org/project/url-normalize/"
+SRC_URI="
+ https://github.com/niksite/url-normalize/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # remove problematic pytest options
+ rm tox.ini || die
+ distutils-r1_src_prepare
+}