summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2021-07-03 13:01:28 +0200
committerSebastian Pipping <sping@gentoo.org>2021-07-03 13:07:50 +0200
commit50cd663733598e3c53c2918ed4f4690740d65b60 (patch)
tree5be499303c1262d8325eb660d3e20caa40bc1353 /dev-python
parentdev-util/cargo-c: Version bump (diff)
downloadgentoo-50cd663733598e3c53c2918ed4f4690740d65b60.tar.gz
gentoo-50cd663733598e3c53c2918ed4f4690740d65b60.tar.bz2
gentoo-50cd663733598e3c53c2918ed4f4690740d65b60.zip
dev-python/pysvn: 1.9.13
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.20, Repoman-3.0.3
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pysvn/Manifest1
-rw-r--r--dev-python/pysvn/files/pysvn-1.9.13-respect-flags.patch124
-rw-r--r--dev-python/pysvn/pysvn-1.9.13.ebuild74
3 files changed, 199 insertions, 0 deletions
diff --git a/dev-python/pysvn/Manifest b/dev-python/pysvn/Manifest
index 1fe4c7275748..deee675c45e1 100644
--- a/dev-python/pysvn/Manifest
+++ b/dev-python/pysvn/Manifest
@@ -1 +1,2 @@
DIST pysvn-1.9.11.tar.gz 624408 BLAKE2B 2ca13388717cc82b68509843e3b1780bceb5c088c41fadc81206c909eb185ec7c73d0a7453fc4e0c1a78a5186e21d382c79af0fb666edce7f5e72c0cf63e25db SHA512 078dc0e19a1f29d40571de002734943415594bcbe132a4d0e6bf8e8781175345ca1b3a4967a183a15efb1462871a40d8e3879a22c913a649555ca593fb99db89
+DIST pysvn-1.9.13.tar.gz 666722 BLAKE2B 4ada83f474026976309b8fc7876dd860fb68eb73dd0a4db0dd0c2838cc029976d5886462705c8b6aa85c5a6f8081f94df61bcbc1698879537fbeb3125154c1a0 SHA512 26ce9af363efb1aee25f8ed73e5bab56208523cb3e7cbe657a5f1145bc3500b2f370b4dfebf4eaace9f566f5676b053c41acb4d01458e4d6b79bd852ac260aa7
diff --git a/dev-python/pysvn/files/pysvn-1.9.13-respect-flags.patch b/dev-python/pysvn/files/pysvn-1.9.13-respect-flags.patch
new file mode 100644
index 000000000000..4070ba6487ad
--- /dev/null
+++ b/dev-python/pysvn/files/pysvn-1.9.13-respect-flags.patch
@@ -0,0 +1,124 @@
+From 9f1d90d7b6ece865af2a23fa412e205cedba4fd4 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Sat, 3 Jul 2021 11:48:09 +0200
+Subject: [PATCH] Respect CC, CXX, LDFLAGS
+
+---
+ Patches/test_proplist.mak | 4 ++--
+ Source/setup_configure.py | 24 ++++++++++--------------
+ 2 files changed, 12 insertions(+), 16 deletions(-)
+
+diff --git a/Patches/test_proplist.mak b/Patches/test_proplist.mak
+index 9d9a58a..02e7a68 100644
+--- a/Patches/test_proplist.mak
++++ b/Patches/test_proplist.mak
+@@ -2,7 +2,7 @@ CCCFLAGS=-fPIC -fexceptions -frtti -I$(SVN_INC) -I$(APR_INC)
+ LDLIBS=-L$(SVN_LIB) -lsvn_client-1 -lapr-0
+
+ test_proplist: test_proplist.o
+- g++ -g -o test_proplist test_proplist.o $(LDLIBS)
++ $(CXX) $(LDFLAGS) -o test_proplist test_proplist.o $(LDLIBS)
+
+ test_proplist.o: test_proplist.cpp
+- g++ -c -g $(CCCFLAGS) -o $@ $<
++ $(CXX) -c $(LDFLAGS) $(CCCFLAGS) -o $@ $<
+diff --git a/Source/setup_configure.py b/Source/setup_configure.py
+index 72c2c8e..fbe6936 100644
+--- a/Source/setup_configure.py
++++ b/Source/setup_configure.py
+@@ -891,8 +891,8 @@ class CompilerGCC(Compiler):
+ def __init__( self, setup ):
+ Compiler.__init__( self, setup )
+
+- self._addVar( 'CCC', 'g++' )
+- self._addVar( 'CC', 'gcc' )
++ self._addVar( 'CCC', '$(CXX)' )
++ self._addVar( 'CC', '$(CC)' )
+
+ def getPythonExtensionFileExt( self ):
+ return '.so'
+@@ -1034,8 +1034,8 @@ class MacOsxCompilerGCC(CompilerGCC):
+ else:
+ arch_options = ''
+
+- self._addVar( 'CCC', 'g++ %s -mmacosx-version-min=%s' % (arch_options, self.macosx_deployment_target) )
+- self._addVar( 'CC', 'gcc %s -mmacosx-version-min=%s' % (arch_options, self.macosx_deployment_target) )
++ self._addVar( 'CCC', '$(CXX) %s -mmacosx-version-min=%s' % (arch_options, self.macosx_deployment_target) )
++ self._addVar( 'CC', '$(CC) %s -mmacosx-version-min=%s' % (arch_options, self.macosx_deployment_target) )
+
+ self._find_paths_pycxx_dir = [
+ '../Import/pycxx-%d.%d.%d' % min_pycxx_version,
+@@ -1101,11 +1101,10 @@ class MacOsxCompilerGCC(CompilerGCC):
+
+ def setupUtilities( self ):
+ self._addVar( 'CCCFLAGS',
+- '-g '
+ '-Wall -fPIC -fexceptions -frtti '
+ '-I. -I%(APR_INC)s -I%(APU_INC)s -I%(SVN_INC)s '
+ '-D%(DEBUG)s' )
+- self._addVar( 'LDEXE', '%(CCC)s -g' )
++ self._addVar( 'LDEXE', '%(CCC)s $(LDFLAGS)' )
+
+ def setupPySvn( self ):
+ # Support building in a virtualenv.
+@@ -1129,7 +1128,6 @@ class MacOsxCompilerGCC(CompilerGCC):
+ self._addVar( 'PYTHON_INC', distutils.sysconfig.get_python_inc() )
+
+ py_cflags_list = [
+- '-g',
+ '-Wall -fPIC',
+ '-I. -I%(APR_INC)s -I%(APU_INC)s -I%(SVN_INC)s',
+ '-DPYCXX_PYTHON_2TO3 -I%(PYCXX)s -I%(PYCXX_SRC)s -I%(PYTHON_INC)s',
+@@ -1159,7 +1157,7 @@ class MacOsxCompilerGCC(CompilerGCC):
+
+ if self.options.hasOption( '--link-python-framework-via-dynamic-lookup' ):
+ # preferred link method on homebrew for pysvn
+- self._addVar( 'LDSHARED', '%(CCC)s -bundle -g '
++ self._addVar( 'LDSHARED', '%(CCC)s -bundle $(LDFLAGS) '
+ '-framework System '
+ '-framework CoreFoundation '
+ '-framework Kerberos '
+@@ -1167,7 +1165,7 @@ class MacOsxCompilerGCC(CompilerGCC):
+ '-undefined dynamic_lookup '
+ '%(LDLIBS)s' )
+ else:
+- self._addVar( 'LDSHARED', '%(CCC)s -bundle -g '
++ self._addVar( 'LDSHARED', '%(CCC)s -bundle $(LDFLAGS) '
+ '-framework System '
+ '%(PYTHON_FRAMEWORK)s '
+ '-framework CoreFoundation '
+@@ -1240,11 +1238,10 @@ class UnixCompilerGCC(CompilerGCC):
+
+ def setupUtilities( self ):
+ self._addVar( 'CCCFLAGS',
+- '-g '
+ '-Wall -fPIC -fexceptions -frtti '
+ '-I. -I%(APR_INC)s -I%(APU_INC)s -I%(SVN_INC)s '
+ '-D%(DEBUG)s' )
+- self._addVar( 'LDEXE', '%(CCC)s -g' )
++ self._addVar( 'LDEXE', '%(CCC)s $(LDFLAGS)' )
+
+ def setupPySvn( self ):
+ self._pysvnModuleSetup()
+@@ -1272,8 +1269,7 @@ class UnixCompilerGCC(CompilerGCC):
+ py_cflags_list.extend( self._getDefines( '-D%s' ) )
+
+ if self.options.hasOption( '--enable-debug' ):
+- print( 'Info: Debug enabled' )
+- py_cflags_list.append( '-g' )
++ print( 'Info: --enable-debug ignored' )
+
+ if self.options.hasOption( '--disable-deprecated-functions-warnings' ):
+ print( 'Info: Disable deprecated functions warnings' )
+@@ -1282,7 +1278,7 @@ class UnixCompilerGCC(CompilerGCC):
+ self._addVar( 'CCFLAGS', ' '.join( py_cflags_list ) )
+ self._addVar( 'CCCFLAGS', ' '.join( py_cflags_list+['-fexceptions -frtti'] ) )
+ self._addVar( 'LDLIBS', ' '.join( self._getLdLibs() ) )
+- self._addVar( 'LDSHARED', '%(CCC)s -shared -g' )
++ self._addVar( 'LDSHARED', '%(CCC)s -shared $(LDFLAGS)' )
+
+ #--------------------------------------------------------------------------------
+ class LinuxCompilerGCC(UnixCompilerGCC):
+--
+2.32.0
+
diff --git a/dev-python/pysvn/pysvn-1.9.13.ebuild b/dev-python/pysvn/pysvn-1.9.13.ebuild
new file mode 100644
index 000000000000..6ed9ff4b7d38
--- /dev/null
+++ b/dev-python/pysvn/pysvn-1.9.13.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_IN_SOURCE_BUILD=true
+DISTUTILS_USE_SETUPTOOLS=bdepend # see setup.py
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Object-oriented python bindings for subversion"
+HOMEPAGE="https://pysvn.sourceforge.io/"
+SRC_URI="mirror://sourceforge/project/pysvn/pysvn/V${PV}/${P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="doc examples"
+
+DEPEND="
+ >=dev-python/pycxx-7.0.2[${PYTHON_USEDEP}]
+ >=dev-vcs/subversion-1.9"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-respect-flags.patch )
+
+python_prepare_all() {
+ # Don't use internal copy of dev-python/pycxx.
+ rm -r Import || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure() {
+ cd Source || die
+ # all config options from 1.7.6 are all already set
+ esetup.py configure
+
+ # Build system mis-assumes that we have a local SVN checkout
+ # that we can query using command "svnversion -c ..".
+ # Revision 2061 is release 1.9.13 according to
+ # https://sourceforge.net/p/pysvn/code/2061/
+ echo $'#! /bin/sh\necho 2061' > "${T}"/fake_svnversion.sh || die
+ chmod a+x "${T}"/fake_svnversion.sh || die
+}
+
+python_compile() {
+ cd Source || die
+ emake \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ WC_SVNVERSION="${T}/fake_svnversion.sh"
+}
+
+python_test() {
+ cd Tests || die
+ emake
+}
+
+python_install() {
+ cd Source || die
+ python_domodule pysvn
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( Docs/. )
+ if use examples; then
+ docinto examples
+ dodoc -r Examples/Client/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}