summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-28 09:02:06 +0200
committerMichał Górny <mgorny@gentoo.org>2021-03-28 11:48:26 +0200
commit547c6b85432cda288537fc60ec1768bc9a5ac0d0 (patch)
tree8195b8c402e38ce7f3c27cdeeb453e3460221af9 /dev-python
parentdev-python/rich: Bump to 10.0.0 (diff)
downloadgentoo-547c6b85432cda288537fc60ec1768bc9a5ac0d0.tar.gz
gentoo-547c6b85432cda288537fc60ec1768bc9a5ac0d0.tar.bz2
gentoo-547c6b85432cda288537fc60ec1768bc9a5ac0d0.zip
dev-python/python-dotenv: Modernize
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-dotenv/python-dotenv-0.16.0.ebuild15
1 files changed, 4 insertions, 11 deletions
diff --git a/dev-python/python-dotenv/python-dotenv-0.16.0.ebuild b/dev-python/python-dotenv/python-dotenv-0.16.0.ebuild
index 327601a0effa..400dad458bc2 100644
--- a/dev-python/python-dotenv/python-dotenv-0.16.0.ebuild
+++ b/dev-python/python-dotenv/python-dotenv-0.16.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{7..9} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -15,9 +15,9 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="test"
-DEPEND="test? (
+DEPEND="
+ test? (
>=dev-python/click-5[${PYTHON_USEDEP}]
dev-python/ipython[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
@@ -26,11 +26,4 @@ DEPEND="test? (
DOCS=( CHANGELOG.md README.md )
-distutils_enable_tests pytest
-
-python_test() {
- # Tests call the "dotenv" command which needs to be in PATH
- # https://bugs.gentoo.org/743784
- distutils_install_for_testing
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}
+distutils_enable_tests --install pytest