summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-03 19:30:03 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-03 19:45:58 +0100
commit58982064bfa7f612910bb0c9374578bb42c73601 (patch)
tree6c44a89a07d85820b3246a94011f44676ae0555c /dev-python
parentapp-emacs/flycheck: Stabilize 32_p20220328-r1 arm64, #889576 (diff)
downloadgentoo-58982064bfa7f612910bb0c9374578bb42c73601.tar.gz
gentoo-58982064bfa7f612910bb0c9374578bb42c73601.tar.bz2
gentoo-58982064bfa7f612910bb0c9374578bb42c73601.zip
dev-python/json5: Bump to 0.9.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/json5/Manifest1
-rw-r--r--dev-python/json5/json5-0.9.11.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/json5/Manifest b/dev-python/json5/Manifest
index a0ac0eca555a..c2bcc53461cd 100644
--- a/dev-python/json5/Manifest
+++ b/dev-python/json5/Manifest
@@ -1 +1,2 @@
DIST pyjson5-0.9.10.gh.tar.gz 111356 BLAKE2B 457bce2988d9e5848784fbd0c75603aa77b7f5d08c71f9849f7459728985ee69085bd5d0d471ae1d9c2291fa2293eedc4be2535da333821a77b01ba3d7e9c1bc SHA512 5e5b04739a47c64b642060a969b11547a7f5490ec9031d526bf90d838f1879958f1fae61644f5ecf67a936dcb7b57ce18de3ee86bece44204758d0eff5e5b8ed
+DIST pyjson5-0.9.11.gh.tar.gz 111445 BLAKE2B 038ac1fab6e56e6dc45dc9bff1fc5e0da21c594cb0ac1f6d888f0207fddace9663b0dbd6abbfabce857cb9fcb40348002b10a6b4133e2f2ebb2081c543e1ad9c SHA512 aca3f38cd79d4bf52ceaf1b3dd27e30bf7598fa0b369216ac820f0c913797ebf542c9eaac17e562ee07006bf83c09210c799bc1b715c7b6e7689d2dcd702d414
diff --git a/dev-python/json5/json5-0.9.11.ebuild b/dev-python/json5/json5-0.9.11.ebuild
new file mode 100644
index 000000000000..981593fae9ad
--- /dev/null
+++ b/dev-python/json5/json5-0.9.11.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=pyjson5-${PV}
+DESCRIPTION="A Python implementation of the JSON5 data format"
+HOMEPAGE="
+ https://github.com/dpranke/pyjson5/
+ https://pypi.org/project/json5/
+"
+SRC_URI="
+ https://github.com/dpranke/pyjson5/archive/refs/tags/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest