summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-06 09:21:39 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-06 11:58:58 +0100
commit633561a4e41cf831ef1847f6286ea8cfc17cee04 (patch)
treedaab76f4826be2ba8e415220db17bd864f388ad0 /dev-python
parentapp-admin/awscli: Bump to 1.21.12 (diff)
downloadgentoo-633561a4e41cf831ef1847f6286ea8cfc17cee04.tar.gz
gentoo-633561a4e41cf831ef1847f6286ea8cfc17cee04.tar.bz2
gentoo-633561a4e41cf831ef1847f6286ea8cfc17cee04.zip
dev-python/xarray: Bump to 0.20.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/xarray/Manifest1
-rw-r--r--dev-python/xarray/xarray-0.20.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/xarray/Manifest b/dev-python/xarray/Manifest
index 20ed015ab110..de272d89dea8 100644
--- a/dev-python/xarray/Manifest
+++ b/dev-python/xarray/Manifest
@@ -1 +1,2 @@
DIST xarray-0.19.0.tar.gz 2882403 BLAKE2B 454595076074c9805f0ff6f8b761a61e4c172445f2fd0bbcbd39a9615f3465704871fbc5f7c1a9c5fbb1c80b6c47cd677e590e1513ca88cd67908ef3502d234e SHA512 8f4ce7f770ea10e757112b722c7e7a56f19be2f885c63620d547cc54d8b625a5a23c5e603ba804c4d94f2a94863aad8351a9f6ef22ccbc1a78d77a549a21356e
+DIST xarray-0.20.1.tar.gz 2896122 BLAKE2B 75dbebab105fb2b0c78d09e6dba30bf90a87d1e0b97b96cacc7f880a34734811dae7ebd6b4858718d70f7e03d99c8d58de9b6091d354831ccd17c3946b44e9b6 SHA512 d2e6162286c7e7debed27f40082086dbb55467a953a2afa81b08313aa111c28ffa942785687ac57cb60241a1f45a5d9a937a10bcc7c3025860f7251bbac79c22
diff --git a/dev-python/xarray/xarray-0.20.1.ebuild b/dev-python/xarray/xarray-0.20.1.ebuild
new file mode 100644
index 000000000000..defa14a3fa95
--- /dev/null
+++ b/dev-python/xarray/xarray-0.20.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# pkg_resources use in code
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="N-D labeled arrays and datasets in Python"
+HOMEPAGE="https://xarray.pydata.org/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/numpy-1.18[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.1[${PYTHON_USEDEP}]"
+# note: most of test dependencies are optional
+BDEPEND="
+ test? (
+ dev-python/bottleneck[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.4[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.19.0-riscv_tests_datetime.patch
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # warning-targeted tests are fragile and not important to end users
+ xarray/tests/test_backends.py::test_no_warning_from_dask_effective_get
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}