summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2016-03-09 01:50:01 +0100
committerDavide Pesavento <pesa@gentoo.org>2016-03-09 01:50:01 +0100
commit6716687c2eaea181568073f26893bdd6df73e808 (patch)
tree5c31bb9d59e905ae69df53cede6598d1a89caa80 /dev-python
parentMerge remote-tracking branch 'remotes/tomboy-64/endless-sky' (diff)
downloadgentoo-6716687c2eaea181568073f26893bdd6df73e808.tar.gz
gentoo-6716687c2eaea181568073f26893bdd6df73e808.tar.bz2
gentoo-6716687c2eaea181568073f26893bdd6df73e808.zip
dev-python/PyQtMobility: treeclean
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/PyQtMobility/Manifest1
-rw-r--r--dev-python/PyQtMobility/PyQtMobility-1.0.1.ebuild91
-rw-r--r--dev-python/PyQtMobility/metadata.xml30
3 files changed, 0 insertions, 122 deletions
diff --git a/dev-python/PyQtMobility/Manifest b/dev-python/PyQtMobility/Manifest
deleted file mode 100644
index 52d36676cbd8..000000000000
--- a/dev-python/PyQtMobility/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST PyQtMobility-gpl-1.0.1.tar.gz 111999 SHA256 8496a47f5345ff547c04e8301cfcdf7862fe9557f56d0d93818c947060b442df SHA512 09bb77f348abe0caf174dea505f3a10ee2adf99698048c9fffc1da66a36dcb907cef7896ee92af7d9ec98a5b30f5229fd9eedc6a64e1476ca340c29b5d842770 WHIRLPOOL 49bbd93b79418f34872a76665d7d54d4a5adca0bdd44a31fe095bfd148d7a673671bc3b61015bc0489d91b7386dc23c57b462e10def00460cc448c165cfe4d8a
diff --git a/dev-python/PyQtMobility/PyQtMobility-1.0.1.ebuild b/dev-python/PyQtMobility/PyQtMobility-1.0.1.ebuild
deleted file mode 100644
index 9477fc0ebadd..000000000000
--- a/dev-python/PyQtMobility/PyQtMobility-1.0.1.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-PYTHON_DEPEND="*"
-PYTHON_EXPORT_PHASE_FUNCTIONS="1"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython 2.7-pypy-*"
-
-inherit python
-
-MY_P=${PN}-gpl-${PV}
-
-DESCRIPTION="Python bindings for Nokia's QtMobility libraries"
-HOMEPAGE="http://sourceforge.net/projects/pyqt/files/PyQtMobility/"
-SRC_URI="mirror://sourceforge/pyqt/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="|| ( GPL-2 GPL-3 )"
-KEYWORDS="~amd64"
-
-PYQTM_MODULES="+contacts feedback gallery location messaging multimedia organizer
- publishsubscribe sensors serviceframework systeminfo versit"
-IUSE="debug ${PYQTM_MODULES}"
-
-REQUIRED_USE="
- || ( ${PYQTM_MODULES//+} )
- versit? ( contacts )
-"
-
-QTM_USE_DEPS=
-for mod in ${PYQTM_MODULES//+}; do
- QTM_USE_DEPS+="${mod}?,"
-done
-unset mod
-
-DEPEND="
- >=dev-python/sip-4.12.2
- >=dev-python/PyQt4-4.8.4[X]
- >=dev-qt/qt-mobility-1.2.0[${QTM_USE_DEPS%,}]
-"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- # Disable pre-stripping of modules
- sed -i -e '/SIPModuleMakefile/s|$|strip=0,|' configure.py || die
-
- python_src_prepare
-}
-
-pyqtm_use_enable() {
- use $1 && echo --enable=${2:-Qt$(echo ${1:0:1} | tr '[:lower:]' '[:upper:]')${1:1}}
-}
-
-src_configure() {
- configuration() {
- local myconf=("$(PYTHON)"
- configure.py
- --destdir="${EPREFIX}$(python_get_sitedir)"
- --sipdir="${EPREFIX}/usr/share/sip"
- $(use debug && echo --debug)
- $(pyqtm_use_enable contacts)
- $(pyqtm_use_enable feedback)
- $(pyqtm_use_enable gallery)
- $(pyqtm_use_enable location)
- $(pyqtm_use_enable messaging)
- $(pyqtm_use_enable multimedia QtMultimediaKit)
- $(pyqtm_use_enable organizer)
- $(pyqtm_use_enable publishsubscribe QtPublishSubscribe)
- $(pyqtm_use_enable sensors)
- $(pyqtm_use_enable serviceframework QtServiceFramework)
- $(pyqtm_use_enable systeminfo QtSystemInfo)
- $(pyqtm_use_enable versit)
- )
- echo "${myconf[@]}"
- "${myconf[@]}"
- }
- python_execute_function -s configuration
-}
-
-pkg_postinst() {
- python_mod_optimize QtMobility
-}
-
-pkg_postrm() {
- python_mod_cleanup QtMobility
-}
diff --git a/dev-python/PyQtMobility/metadata.xml b/dev-python/PyQtMobility/metadata.xml
deleted file mode 100644
index 1a5e5926ae88..000000000000
--- a/dev-python/PyQtMobility/metadata.xml
+++ /dev/null
@@ -1,30 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>qt@gentoo.org</email>
- <name>Gentoo Qt Project</name>
- </maintainer>
- <use>
- <flag name="contacts">Build bindings for the QtContacts module</flag>
- <flag name="feedback">Build bindings for the QtFeedback module</flag>
- <flag name="gallery">Build bindings for the QtGallery module</flag>
- <flag name="location">Build bindings for the QtLocation module</flag>
- <flag name="messaging">Build bindings for the QtMessaging module</flag>
- <flag name="multimedia">Build bindings for the QtMultimediaKit module</flag>
- <flag name="organizer">Build bindings for the QtOrganizer module</flag>
- <flag name="publishsubscribe">Build bindings for the QtPublishSubscribe module</flag>
- <flag name="sensors">Build bindings for the QtSensors module</flag>
- <flag name="serviceframework">Build bindings for the QtServiceFramework module</flag>
- <flag name="systeminfo">Build bindings for the QtSystemInfo module</flag>
- <flag name="versit">Build bindings for the QtVersit module</flag>
- </use>
- <upstream>
- <maintainer status="active">
- <email>phil@riverbankcomputing.com</email>
- <name>Phil Thompson</name>
- </maintainer>
- <bugs-to>mailto:pyqt@riverbankcomputing.com</bugs-to>
- <remote-id type="sourceforge">pyqt</remote-id>
- </upstream>
-</pkgmetadata>