summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-29 08:14:52 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-29 09:48:23 +0100
commit73ecb0163c734e1ff4cf68862b6b3a82fbd4b201 (patch)
treeaefc4787d8ff3d0e61b52ef7af8f9efd24e92a71 /dev-python
parentdev-python/fonttools: Bump to 4.55.7 (diff)
downloadgentoo-73ecb0163c734e1ff4cf68862b6b3a82fbd4b201.tar.gz
gentoo-73ecb0163c734e1ff4cf68862b6b3a82fbd4b201.tar.bz2
gentoo-73ecb0163c734e1ff4cf68862b6b3a82fbd4b201.zip
dev-python/python-socks: Bump to 2.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-socks/Manifest1
-rw-r--r--dev-python/python-socks/python-socks-2.7.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/python-socks/Manifest b/dev-python/python-socks/Manifest
index 4ff60428697c..1387ac995cc0 100644
--- a/dev-python/python-socks/Manifest
+++ b/dev-python/python-socks/Manifest
@@ -1 +1,2 @@
DIST python-socks-2.6.1.gh.tar.gz 32352 BLAKE2B 0bfc85bdeb6aefab34d307a6956171fad8b0876f49959bfc91193c864ba8ed7d05a1efb4f052202d99984aad7bb9bfc8472e2853d57b5812156dec6ee791a04e SHA512 2e046849a66125ddb14f887f84354e56f689034695a48532cbd4d4a1ef9508212c30e34faeb3b318ceede32a0604d62f92ca92cfe14b63c54a42fd5c1cfafbc0
+DIST python-socks-2.7.0.gh.tar.gz 32361 BLAKE2B 603e9782ee2998825bbcff012e1eeba7e404f13112544c6db97e5baf31ac79cb9339d98642c20a56fc5a1ef7da4a60687e663770ec0c145015648c07f99c341d SHA512 0244a6111ba37341e06210422af1df5946edd0e87616647aa2bbaf0cb82c363db3489eeddbd2111cbb76a126b5d629a2426776316b7ea68a17d3aa4fea2901f1
diff --git a/dev-python/python-socks/python-socks-2.7.0.ebuild b/dev-python/python-socks/python-socks-2.7.0.ebuild
new file mode 100644
index 000000000000..841c4392d877
--- /dev/null
+++ b/dev-python/python-socks/python-socks-2.7.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2020-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="SOCKS4, SOCKS5, HTTP tunneling functionality for Python"
+HOMEPAGE="
+ https://github.com/romis2012/python-socks/
+ https://pypi.org/project/python-socks/
+"
+SRC_URI="
+ https://github.com/romis2012/python-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# curio is not packaged
+# asyncio is the only backend we have, so dep on its deps unconditionally
+# TODO: revisit
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/async-timeout-4.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/async-timeout-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-trio-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/tiny-proxy-0.1.1[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.24[${PYTHON_USEDEP}]
+ >=dev-python/trustme-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/yarl-1.4.2[${PYTHON_USEDEP}]
+ )
+"
+
+# Test markers exist to exclude trio etc if needed
+distutils_enable_tests pytest