summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-31 05:56:25 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-31 05:56:25 +0100
commit82e06e7b5fd0775ca421190bce25c1835d0216a0 (patch)
tree7f7f3c2ee9b6d13834c65b26dddc731b6ae33826 /dev-python
parentdev-python/rapidfuzz: Bump to 3.12.1 (diff)
downloadgentoo-82e06e7b5fd0775ca421190bce25c1835d0216a0.tar.gz
gentoo-82e06e7b5fd0775ca421190bce25c1835d0216a0.tar.bz2
gentoo-82e06e7b5fd0775ca421190bce25c1835d0216a0.zip
dev-python/weasyprint: Bump to 64.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/weasyprint/Manifest1
-rw-r--r--dev-python/weasyprint/weasyprint-64.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/weasyprint/Manifest b/dev-python/weasyprint/Manifest
index a0adafdcec59..c13c9f773fd1 100644
--- a/dev-python/weasyprint/Manifest
+++ b/dev-python/weasyprint/Manifest
@@ -1 +1,2 @@
DIST weasyprint-63.1.tar.gz 491880 BLAKE2B 564c52abe3299aa2c51733c883c59ea0581953e067c003377cf0456412bd0cc49f38a03ea46f9cc6e3a3eb4c8df4daa1359996e0525bd9420b1720a26a393877 SHA512 1fda3126dd5c028b42515819f58153092d1607ea5a327a8668cd11ce44aa2b73d7340c04825ce80486881ac1b0dcfe789ffaec277f7a81465efc9067b9b9c87c
+DIST weasyprint-64.0.tar.gz 498075 BLAKE2B 572bac1f70476d63f8f40e3ace90e534bbe69c5a071bbe1e9de7bb8d1c5b06b150d9e7ad7261e74d0c6aeb740b9889608e22bf71b7e01e0d313a1dc546b58fe8 SHA512 46e65777804d53174bb3020b1418d19c0bf815667d020c40fb7de567439272df65d74ab941fdb37edc7f1d4f06430d3ebaa65f8ce13c887235e39c51cefb3930
diff --git a/dev-python/weasyprint/weasyprint-64.0.ebuild b/dev-python/weasyprint/weasyprint-64.0.ebuild
new file mode 100644
index 000000000000..d62e3bc92379
--- /dev/null
+++ b/dev-python/weasyprint/weasyprint-64.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF"
+HOMEPAGE="
+ https://weasyprint.org/
+ https://github.com/Kozea/WeasyPrint/
+ https://pypi.org/project/weasyprint/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cffi-0.6:=[${PYTHON_USEDEP}]
+ >=dev-python/cssselect2-0.1[${PYTHON_USEDEP}]
+ >=dev-python/fonttools-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pillow-9.1.0[jpeg,jpeg2k,${PYTHON_USEDEP}]
+ >=dev-python/pydyf-0.11.0[${PYTHON_USEDEP}]
+ >=dev-python/pyphen-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/tinycss2-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/tinyhtml5-2.0.0[${PYTHON_USEDEP}]
+ media-fonts/dejavu
+ x11-libs/pango
+"
+
+BDEPEND="
+ test? (
+ >=app-text/ghostscript-gpl-9.56.1-r3
+ media-fonts/ahem
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}