summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-10 06:07:13 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-10 07:21:14 +0100
commit8361194ef450f7aa7ba0fb4284bd70053086f1a4 (patch)
treeecba53f240624abfbcd7506aa2dd437438b5e2e5 /dev-python
parentapp-admin/awscli: Bump to 1.27.46 (diff)
downloadgentoo-8361194ef450f7aa7ba0fb4284bd70053086f1a4.tar.gz
gentoo-8361194ef450f7aa7ba0fb4284bd70053086f1a4.tar.bz2
gentoo-8361194ef450f7aa7ba0fb4284bd70053086f1a4.zip
dev-python/cloudscraper: Bump to 1.2.68
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cloudscraper/Manifest1
-rw-r--r--dev-python/cloudscraper/cloudscraper-1.2.68.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/cloudscraper/Manifest b/dev-python/cloudscraper/Manifest
index da43c4fbd55f..5b568681dc2d 100644
--- a/dev-python/cloudscraper/Manifest
+++ b/dev-python/cloudscraper/Manifest
@@ -1 +1,2 @@
DIST cloudscraper-1.2.65.gh.tar.gz 111946 BLAKE2B 7b53819ceb3349c9e8bc24cfd3138119b46bd88daa639d1c29b7e7477f0fc2cb323b3e485832236eadf48be76d16a2dde93cadffe594fc7b7d43b24651de45eb SHA512 e885e7e0b7e91318da4b6d65165961fbae27951be9b4f05af96e7eeaf1e28e1146af52c10bf0b769f07fc04016998eed9146ec92504a591d81434a101c6d6850
+DIST cloudscraper-1.2.68.gh.tar.gz 111952 BLAKE2B 69e896ad704ce776594fb89714bb75316ebff1b03387cba8575be6d60b496d18556690cfad109c2fa55c72ce3d91dcd21a21467a2d9820c579fea7482b688800 SHA512 42fa90127c6348c52a8327728683719966ae69c7b945cb9b485907e89e3b29b8053d31cd9cd4326e71ffd4c33e0fce20dd3d0e046fab62d89110eb4510535ad9
diff --git a/dev-python/cloudscraper/cloudscraper-1.2.68.ebuild b/dev-python/cloudscraper/cloudscraper-1.2.68.ebuild
new file mode 100644
index 000000000000..a1c5530419a1
--- /dev/null
+++ b/dev-python/cloudscraper/cloudscraper-1.2.68.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A Python module to bypass Cloudflare's anti-bot page"
+HOMEPAGE="
+ https://github.com/VeNoMouS/cloudscraper/
+ https://pypi.org/project/cloudscraper/
+"
+SRC_URI="
+ https://github.com/VeNoMouS/cloudscraper/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+RDEPEND="
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/requests-toolbelt[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/js2py[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ net-libs/nodejs
+ )
+"
+
+# These tests fail for no understanadble reason
+EPYTEST_DESELECT=(
+ "tests/test_cloudscraper.py::TestCloudScraper::test_bad_interpreter_js_challenge1_16_05_2020"
+ "tests/test_cloudscraper.py::TestCloudScraper::test_bad_solve_js_challenge1_16_05_2020"
+ "tests/test_cloudscraper.py::TestCloudScraper::test_Captcha_challenge_12_12_2019"
+ "tests/test_cloudscraper.py::TestCloudScraper::test_reCaptcha_providers"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "brotli decompresssion support" "dev-python/brotlipy"
+
+ optfeature "js2py interpreter support" "dev-python/js2py"
+ optfeature "node.js interpreter support" "net-libs/nodejs"
+}