summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-23 10:26:59 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-23 10:27:28 +0100
commit8fae3bf58c2224355646bc6fca700feff3609bf9 (patch)
treef0162272adab60df210cefe9aa014a95ce6b5a0d /dev-python
parentmedia-libs/oneVPL-intel-gpu: drop 22.6.3, 22.6.4 (diff)
downloadgentoo-8fae3bf58c2224355646bc6fca700feff3609bf9.tar.gz
gentoo-8fae3bf58c2224355646bc6fca700feff3609bf9.tar.bz2
gentoo-8fae3bf58c2224355646bc6fca700feff3609bf9.zip
dev-python/pyzmq: add 25.0.0
Closes: https://bugs.gentoo.org/805584 Closes: https://bugs.gentoo.org/805581 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyzmq/Manifest1
-rw-r--r--dev-python/pyzmq/metadata.xml1
-rw-r--r--dev-python/pyzmq/pyzmq-25.0.0.ebuild90
3 files changed, 92 insertions, 0 deletions
diff --git a/dev-python/pyzmq/Manifest b/dev-python/pyzmq/Manifest
index 9f8bb2a33acd..475d8b9310de 100644
--- a/dev-python/pyzmq/Manifest
+++ b/dev-python/pyzmq/Manifest
@@ -1 +1,2 @@
DIST pyzmq-24.0.1.gh.tar.gz 404000 BLAKE2B 01928ba3c64a5afce8e7a97821658da2067a5f6c36c0173ab2f818e83a729939f346ef67bb9a39251abf365f5772abdf7e9e62afb4cc434b5603f474485a7427 SHA512 d4b6346e780f356941a624321f1619771fb2f0ef9f65a3c0a03e837ef081ece7ed59c03f57e8647ab1cd38cfc7404d597dd294768f9e9b890115b9eebc085484
+DIST pyzmq-25.0.0.gh.tar.gz 387190 BLAKE2B aba258637fa698e3e2241c36b561d76971a82d20137573ed75bacf429cd21e2f2cbf6c15c76e7c6a9f2e3d7acd7cb03e5091f71bb41d6365c93d670a2cc81392 SHA512 9a4f25f6a9f6a9e636c7d50af69ee9d4629503fd707f6cd17772430f71bd386a573e5eed19eca0419ce0a3ca1f811601c785b5b6b9749b5cf03654a97c2afaf6
diff --git a/dev-python/pyzmq/metadata.xml b/dev-python/pyzmq/metadata.xml
index f3cb0b82106a..8b18d4ba0094 100644
--- a/dev-python/pyzmq/metadata.xml
+++ b/dev-python/pyzmq/metadata.xml
@@ -15,5 +15,6 @@
</upstream>
<use>
<flag name="draft">Enable draft API support</flag>
+ <flag name="drafts">Enable draft API support</flag>
</use>
</pkgmetadata>
diff --git a/dev-python/pyzmq/pyzmq-25.0.0.ebuild b/dev-python/pyzmq/pyzmq-25.0.0.ebuild
new file mode 100644
index 000000000000..62e3e834ee47
--- /dev/null
+++ b/dev-python/pyzmq/pyzmq-25.0.0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+# TODO: Find out exactly where this error comes from
+# error: '<' not supported between instances of 'str' and 'int'
+#DISTUTILS_USE_PEP517=setuptools
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Lightweight and super-fast messaging library built on top of the ZeroMQ library"
+HOMEPAGE="
+ https://zeromq.org/languages/python/
+ https://pypi.org/project/pyzmq/
+ https://github.com/zeromq/pyzmq/"
+SRC_URI="
+ https://github.com/zeromq/pyzmq/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="drafts"
+
+# There are additional test failures if zeromq has the draft api enabled, but pyzmq has it disabled.
+DEPEND="
+ >=net-libs/zeromq-4.2.2-r2:=[drafts=]
+"
+# It uses cffi backend for pypy, cython backend for cpython
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/py[${PYTHON_USEDEP}]
+ dev-python/cffi:=[${PYTHON_USEDEP}]
+ ' pypy3)
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ' 'python*')
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ >=dev-python/tornado-5.0.2[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-23.2.0-libdir.patch
+)
+
+EPYTEST_DESELECT=(
+ # TODO
+ zmq/tests/test_constants.py::TestConstants::test_draft
+ zmq/tests/test_cython.py::test_cython
+
+ # Hangs often
+ zmq/tests/test_log.py::TestPubLog::test_blank_root_topic
+)
+
+EPYTEST_IGNORE=(
+ # Avoid dependency on mypy
+ zmq/tests/test_mypy.py
+
+ # Broken upstream
+ zmq/tests/test_auth.py
+
+ # pytest-asyncio incompatibility?
+ zmq/tests/test_zmqstream.py
+)
+
+distutils_enable_tests pytest
+# TODO: Package enum_tools
+# distutils_enable_sphinx docs/source \
+# dev-python/numpydoc \
+# dev-python/sphinx-rtd-theme \
+# dev-python/myst_parser
+
+python_prepare_all() {
+ export ZMQ_DRAFT_API=$(usex drafts '1' '0')
+ export ZMQ_PREFIX="${EPREFIX}/usr"
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${BUILD_DIR}/lib" || die
+ epytest -p no:flaky
+}