summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-22 05:25:16 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-22 06:38:43 +0100
commita0e2c28843ad56b91e05e6ca5fa0f8aaff587ca5 (patch)
tree72fb0bcebae5a3439c31d9c1411b6bc77087cbb3 /dev-python
parentdev-python/hypercorn: Stabilize 0.16.0 hppa, #922562 (diff)
downloadgentoo-a0e2c28843ad56b91e05e6ca5fa0f8aaff587ca5.tar.gz
gentoo-a0e2c28843ad56b91e05e6ca5fa0f8aaff587ca5.tar.bz2
gentoo-a0e2c28843ad56b91e05e6ca5fa0f8aaff587ca5.zip
dev-python/botocore: Bump to 1.34.47
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.34.47.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 575b2c93a062..0ca3c8ead5d3 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -3,3 +3,4 @@ DIST botocore-1.34.39.gh.tar.gz 12697404 BLAKE2B d8670c591c06cf5b02562adb234225d
DIST botocore-1.34.44.gh.tar.gz 12716767 BLAKE2B 335d59ae57ae5a5a1bdb44c3e196dff18cb24dd4a4d3beb59e7b8e887d5cc56f0716b2e4fead0c9a4c96978d661308fb0f1e045300e7af69c94ed799bb25a2ef SHA512 12893173c0123711f496448e661bb8e463fcc29ac95c500fe427e2dcf9810659b92de1d38ec3192e1e20a92ca01a5315733f34d0ffe61f2c9b69763e427ee96f
DIST botocore-1.34.45.gh.tar.gz 12726866 BLAKE2B c5095199626afcd7d83ff62623593f1863aa068a05347adcc738b1b168e8f0f224d6370bd05f71f8fa72dd0f2180067016d37956b332d6cfa42ea5e68c4d9bb3 SHA512 2aff40aa39a431bd9ee99ee30e136051e2b9039dc2bbdd6a36bd1108e470f6dbda5ad23534b9b148799b27d4c7eb0806698ae2f05dbee94a6ff6ee3fe087dcf1
DIST botocore-1.34.46.gh.tar.gz 12726577 BLAKE2B 0c1574bd5e045bc478e44f300d64d5d56489246ad7cddc1ae19e2ad9080abbf30985330e435b833acfb1f1ded46e60ee2e70e1273568a93b69a47018df68ff4a SHA512 9ff234090e3a315612cd97e36ec5eb577d799465c4bb99ef1a5b2efbd83ce3cd5de94300996381c704896efd6bbb612a9b76831040dfd68f9cf86a821680b24b
+DIST botocore-1.34.47.gh.tar.gz 12728346 BLAKE2B c1b596764ebb5c02cc9ae925e1b8610e4eb425a8adfd55434790f187c80470a78a670c4d78af15cbb08bacd35d4ff118a5eda379d086ae721510d08670984a79 SHA512 d65db0a8cd4d1e3558a493c067e894c40ca9a0cd514e488bc8f346d745b2b81d7b77f2f2161f2c14e69f7a22b891eb81465f637669df9ca8bd8f8ab73ac2e2ed
diff --git a/dev-python/botocore/botocore-1.34.47.ebuild b/dev-python/botocore/botocore-1.34.47.ebuild
new file mode 100644
index 000000000000..ba6cd2a5d2a2
--- /dev/null
+++ b/dev-python/botocore/botocore-1.34.47.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}